<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"  />
<title>80 Years of Mopar Celebration Kickoff &laquo;  DragRaceCanada.com</title>
<meta name="generator" content="WordPress 4.7.2" />
<meta name="robots" content="follow, all" />

<link rel="shortcut icon" href="http://dragracecanada.com/wp-content/themes/jarrah/favicon.ico" />
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="DragRaceCanada.com RSS Feed" href="http://dragracecanada.com/feed/" />
<link rel="pingback" href="http://dragracecanada.com/xmlrpc.php" />
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/css/menu.css" type="text/css" media="screen" />
<!--[if IE]><link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/css/ie.css" type="text/css" media="screen" /><![endif]-->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/dragracecanada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='http://dragracecanada.com/wp-content/plugins/ditty-news-ticker/assets/fontastic/styles.css?ver=2.0.15' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='http://dragracecanada.com/wp-content/plugins/ditty-news-ticker/assets/css/style.css?ver=2.0.15' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='http://dragracecanada.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://dragracecanada.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.0.3' type='text/css' media='all' />
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/flash-album-gallery/admin/js/swfobject.js?ver=2.2'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/flash-album-gallery/admin/js/swfaddress.js?ver=2.4'></script>
<link rel='https://api.w.org/' href='http://dragracecanada.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://dragracecanada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://dragracecanada.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='2017 NHRA Schedule' href='http://dragracecanada.com/2017-nhra-schedule/' />
<meta name="generator" content="WordPress 4.7.2" />
<link rel="canonical" href="http://dragracecanada.com/80-years-of-mopar-celebration-kickoff/" />
<link rel='shortlink' href='http://wp.me/p1LMBY-6JJ' />
<link rel="alternate" type="application/json+oembed" href="http://dragracecanada.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragracecanada.com%2F80-years-of-mopar-celebration-kickoff%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://dragracecanada.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragracecanada.com%2F80-years-of-mopar-celebration-kickoff%2F&#038;format=xml" />
<script type='text/javascript'>AC_FL_RunContent = 0;</script><script type='text/javascript' src="http://dragracecanada.com/wp-content/plugins/dynamic-headers/AC_RunActiveContent.js"></script><link rel="stylesheet" href="http://dragracecanada.com/wp-content/plugins/logo-slideshow/css/image-slideshow.css" type="text/css" media="screen" charset="utf-8"/>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/image-slideshow.js"></script>
	
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/plugins/wp-photo-album/theme/wppa_style.css" type="text/css" media="screen" />
		
<!-- <meta name='Grand Flagallery' content='4.41' /> -->

<link rel='dns-prefetch' href='//v0.wordpress.com'>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="80 Years of Mopar Celebration Kickoff" />
<meta property="og:url" content="http://dragracecanada.com/80-years-of-mopar-celebration-kickoff/" />
<meta property="og:description" content="The iconic Mopar and Dodge brands will start both a championship chase &amp; 80th celebration as NHRA’s season blasts off….." />
<meta property="article:published_time" content="2017-02-06T21:56:29+00:00" />
<meta property="article:modified_time" content="2017-02-06T22:03:19+00:00" />
<meta property="og:site_name" content="DragRaceCanada.com" />
<meta property="og:image" content="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Matt-400.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="250" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Matt-400.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.pngFix.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.easing.min.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.lavalamp.min.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/my-menu.js"></script>

<!-- this product is released under General Public License. Please see the attached file for details. You can also find details about the license at http://www.opensource.org/licenses/gpl-license.php -->
<script type="text/javascript">
/* <![CDATA[ */

jQuery(document).ready(function(){ 
    jQuery(document).pngFix(); 
});

/* ]]> */ 
</script>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21904869-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<style type="text/css">

/* banner rotator styles */
div#banner_rotator  {
    width:960px; height:80px;
    padding:0px;
    background-color:#000;
}

div#banner_rotator span {
    display: block; text-align: center;
}

div#banner_rotator a:link,
div#banner_rotator a:visited, 
div#banner_rotator a:hover {
    color:#0F2F8D;
    text-decoration:none;
}

</style>

<script src="http://www.dragracecanada.com/js/dw_rotate_banner.js" type="text/javascript"></script>
<script type="text/javascript">

DYN_WEB.Event.domReady( function() {
    
    var banner = {
        id: 'banner_rotator', // id of element that displays rotating content
        speed: 6000, // default 4500
        bPause: false, // pause/resume onmouseover/out
        // banner content goes here
        // commas separate items, but no comma after last item
        content: ['<a href="http://www.mopar.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2016/12/high-performance-1.jpg" border="0"></span></a>',
            '<a href="http://www.lucasoil.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LucasOil-banner-2017.jpg" border="0"></span></a>',
	    '<a href="http://www.loudmusicloudcars.com/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LMLC-960X80-1.jpg" border="0"></span></a>'
        ]
    };
    
    new DYN_WEB.Banner_Rotator(banner);
    
});

</script>
</head>

<body>

<div id="wrapper" align="center">
	<div id="layouttop"></div>
    
    <!-- Header Starts -->
    <div id="header" align="center">
	<a href="http://www.dragracecanada.com/">
	    <img src="http://dragracecanada.com/wp-content/uploads/2014/12/DRC_Logo_trans.png" border="0">
	</a>
	<SPAN STYLE="font-family: Arial; font-size: 16px; font-decoration: bold; font-style: italic ; color: #FFFFFF"><br>proudly presented by:&nbsp;&nbsp;</SPAN>
	<br>
	<br>
	<div id="banner_rotator"><a href="http://www.lucasoil.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LucasOil-banner-2017.jpg" border="0"></span></a></div>
    	<!-- 				<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="990" height="150" id="mediaHeader" align="middle">
				<param name="allowScriptAccess" value="sameDomain" />
				<param name="allowFullScreen" value="false" />
				<param name="wmode" value="transparent" />
				<param name="movie" value="http://dragracecanada.com/wp-content/header-images/DRC2013.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" />	
				<embed src="http://dragracecanada.com/wp-content/header-images/DRC2013.swf" wmode="transparent" quality="high" bgcolor="#ffffff" width="990" height="150" name="mediaHeader" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
				</object>
		 -->        
    </div>
    <!-- Header Ends -->

    <div id="innerwrapper">

    	
        <!-- Main nav Starts here -->
<!--
        <div id="navouter">
            <div id="nav">

<ul class="lavalamp" id="menu1">  
<li class="page_item "><a href="http://dragracecanada.com">Home</a></li> 
		<li class="cat-item cat-item-13"><a href="http://dragracecanada.com/category/editors-extra/" >Editor&#039;s Extra</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://dragracecanada.com/category/hotzone/" >Hotzone</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://dragracecanada.com/category/international-dateline/" >Int&#039;l Dateline</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://dragracecanada.com/category/national-news/" >National News</a>
</li>
	<li class="cat-item cat-item-9"><a href="http://dragracecanada.com/category/northern-exposure/" >Northern Exposure</a>
</li>
	<li class="cat-item cat-item-10"><a href="http://dragracecanada.com/category/performance-pipeline/" >Perf. Pipeline</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://dragracecanada.com/category/photo-gallery/" >Photo Gallery</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://dragracecanada.com/category/the-pro-mod-portal/" >PM Portal</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://dragracecanada.com/category/uncategorized/" >Uncategorized</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://dragracecanada.com/category/team-blogs/" title="Team Blogs">Your Race Team</a>
</li>
		 	
</ul> 
          
            </div>
        </div>
 //-->
        <!-- Main nav Ends -->
<div id="maincol">

<br><div align="center"><a href="http://www.winnerschoiceracing.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/01/winnerschoice_banner.gif" width="570" height="70" border="0"></a></div><br>
		
        <div class="postwrap">
          	<h2 class="posttitle"><a href="http://dragracecanada.com/80-years-of-mopar-celebration-kickoff/">80 Years of Mopar Celebration Kickoff</a></h2>
          	<div class="postmeta">by <a href="http://dragracecanada.com/author/editor/" title="Posts by editor" rel="author">editor</a> on Feb.06, 2017, under <a href="http://dragracecanada.com/category/performance-pipeline/" rel="category tag">Perf. Pipeline</a></div>
            <div class="clr16"></div>
          	<div class="postcontent"><p><em>The iconic Mopar and Dodge brands will start both a championship chase &amp; <strong>80th</strong> celebration as NHRA’s season blasts off…..</em><span id="more-25899"></span><br />
<a href="http://dragracecanada.com/80-years-of-mopar-celebration-kickoff/mopar-hemi-3/" rel="attachment wp-att-25895"><img class="aligncenter size-full wp-image-25895" src="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Hemi.jpg" alt="" width="500" height="346" srcset="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Hemi.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Hemi-300x208.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Hemi-397x275.jpg 397w" sizes="(max-width: 500px) 100vw, 500px" /></a>When the fastest race cars on the planet roar to life this week for the NHRA Winternationals, a fleet of Mopar-powered Dodge machines will be among the front-runners at Auto Club Raceway at Pomona in Southern California. Drivers and teams will also continue the yearlong Mopar 80th anniversary celebration at the 2017 season-starter as they look to add to the brand&#8217;s rich drag racing tradition.<br />
<a href="http://dragracecanada.com/big-tent-announcement/mopar_logo-svg/" rel="attachment wp-att-25820"><img class="alignleft size-medium wp-image-25820" src="http://dragracecanada.com/wp-content/uploads/2017/01/Mopar_logo.svg_-300x289.png" alt="" width="300" height="289" /></a><br />
The stout, four-driver NHRA Funny Car stable at Don Schumacher Racing (DSR) will look to mark the brand&#8217;s 80 years by capturing a fifth NHRA Mello Yello Series title in the past seven seasons. Longtime Mopar-powered DSR driver Ron Capps gained the title of World Champion for the first time in 2016. His championship run began in Pomona where he collected the victory in the first event of the season. Capps went on to win a total of five races in 10 finals appearances and will return to defend his crown in the NAPA Auto Parts Dodge Charger R/T.</p>
<p>Meanwhile, 2011 and 2014 Funny Car Champion Matt Hagan seeks to dethrone teammate Capps. Hagan finished third in his Mopar Express Lane Dodge Charger R/T in the Funny Car points standings last season, collecting four wins along the way, and also set dual national records. Hagan was responsible for the lowest E.T. in Funny Car history by turning in a time of 3.822 seconds at Minnesota&#8217;s Brainerd International Raceway in August. He also set the record for speed, reaching a staggering 335.57 mph at Heartland Park Topeka in May.</p>
<p>Just as much a threat for race wins and world titles are 2012 champ Jack Beckman and 2016 championship runner-up Tommy Johnson Jr., in the Infinite Hero and Make-A-Wish Dodge Charger R/T machines, respectively. Beckman won twice in 2016 and is also second in lowest E.T., having turned in a pass of 3.825 seconds during last season&#8217;s fall Pomona event. Johnson earned three event wins last year, including at the Pomona season finale.</p>
<p>In the Top Fuel class, Leah Pritchett will compete in her first full season with DSR after coming onboard with the team midway</p>
<div id="attachment_25898" style="width: 229px" class="wp-caption alignright"><a href="http://dragracecanada.com/mopar-leah2/"><img class="size-medium wp-image-25898" src="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Leah2-219x300.jpg" alt="" width="219" height="300" srcset="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Leah2-219x300.jpg 219w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Leah2-201x275.jpg 201w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Leah2.jpg 500w" sizes="(max-width: 219px) 100vw, 219px" /></a><p class="wp-caption-text">Leah Pritchett</p></div>
<p>through the 2016 campaign. A winner last year at Wild Horse Pass Motorsports Park near Phoenix and a top-ten finisher in the standings, Pritchett proved she&#8217;s ready to build on that solid season as she battles in her Mopar/Pennzoil Top Fuel Dragster. During Nitro Spring Training in Phoenix on Saturday, Pritchett recorded the unofficial quickest elapsed time in drag racing history, clocking a run of 3.654 seconds at 331.85 mph.</p>
<p>Pritchett will compete alongside one of the most successful Top Fuel drivers in history, eight-time champion Tony Schumacher, as he pilots the Mopar-powered U.S. Army Top Fuel Dragster.</p>
<p>Pietro Gorlier, Head of Parts and Service (Mopar) FCA &#8211; Global said:</p>
<p>&#8220;The 2016 season was a banner one for Mopar, with Ron Capps winning his first Funny Car World Championship and Mopar and Dodge collecting the NHRA Manufacturers Cup. Mopar is celebrating 80 years in 2017, and over eight decades the dragstrip has always figured prominently in our DNA. Once again, we will field an elite lineup of drivers and teams ready to add to our brand&#8217;s championship-winning legacy at the track.&#8221;</p>
<div id="attachment_25892" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/mopar-capps2/" rel="attachment wp-att-25892"><img class="size-full wp-image-25892" src="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Capps2.jpg" alt="" width="500" height="315" srcset="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Capps2.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Capps2-300x189.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Capps2-400x252.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Defending NHRA Funny Car World Champion &#8211; Ron Capps</p></div>
<p>Several HEMI®-powered Dodge Dart cars will also compete in the Pro Stock ranks, led by veteran Mopar driver Allen Johnson. Mopar pro and Sportsman drivers will also attempt to repeat the cumulative success that helped earn Mopar and Dodge the prestigious NHRA Manufacturers Cup in 2016.</p>
<p>In 2017, Mopar and Dodge are also putting extra emphasis on Sportsman racing with a new program designed to provide incentives to Mopar Dodge Challenger Drag Pak racers. The Magneti Marelli Offered by Mopar Drag Pak Rewards program will offer monetary incentives to racers running that particular car and package. The Top 20 drivers in the final point standings will be eligible for cash prizes, while rewards are also available for a Factory Stock Showdown win and a Stock Eliminator World Championship.</p>
<p><a href="http://dragracecanada.com/mopar-dragpak/"><img class="aligncenter size-full wp-image-25893" src="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-DragPak.jpg" alt="" width="500" height="345" srcset="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-DragPak.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-DragPak-300x207.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-DragPak-400x275.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
<p>All Mopar Sportsman racers will continue to be eligible for awards under the Mopar contingency program, while a variety of special events are scheduled for Sportsman racers through the year. FCA US LLC engineers will provide on-site support to Mopar and Dodge racers across all Sportsman divisions during each of the 24 national events as well.</p>
<p><strong>Mopar and Dodge on Manufacturers Midway</strong></p>
<p>The Mopar display trailer will be on hand on Manufacturers Midway at 15 of the 24 stops on the national event calendar, offering fans a view of the latest Mopar products and hosting special events, such as driver autograph signings. The first signing event is slated for 11:30 a.m. PT on Saturday, February 11, in Pomona.</p>
<p>A brand-new Dodge exhibit will also join the Mopar rig at each event, with the full-scale Dodge display to debut at the NHRA Gatornationals in March. The brands will also serve as primary sponsors at two events on the NHRA schedule: the Mopar Mile-High NHRA Nationals, set for July 21-23 near Denver, Colorado, and the Dodge NHRA Nationals, scheduled for September 21-24 in Reading, Pennsylvania.</p>
<p><a href="http://dragracecanada.com/dodge_nhraf8ml6lq6srvqlpdoq52atigi8n-1-e1474404095215/"><img class="aligncenter size-full wp-image-25906" src="http://dragracecanada.com/wp-content/uploads/2017/02/dodge_nhraf8ml6lq6srvqlpdoq52atigi8n-1-e1474404095215.jpg" alt="" width="487" height="103" srcset="http://dragracecanada.com/wp-content/uploads/2017/02/dodge_nhraf8ml6lq6srvqlpdoq52atigi8n-1-e1474404095215.jpg 487w, http://dragracecanada.com/wp-content/uploads/2017/02/dodge_nhraf8ml6lq6srvqlpdoq52atigi8n-1-e1474404095215-300x63.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/02/dodge_nhraf8ml6lq6srvqlpdoq52atigi8n-1-e1474404095215-400x85.jpg 400w" sizes="(max-width: 487px) 100vw, 487px" /></a><br />
<strong>Matt Hagan, driver, Mopar Express Lane Dodge Charger R/T</strong></p>
<p>&#8220;2017 is going to be a big year I think for all of us, especially here at DSR. I have a lot of goals that I&#8217;ve set for myself. With my brother passing, I think that it put some stuff in perspective for me, treating every day and every lap and every race as it could be your last. He was 33 years old and he&#8217;s gone. Somehow that stuff hits home. You&#8217;ve got to take life and really realize how special every moment is. So, I think that when I&#8217;m crawling into the racecar this year I&#8217;m not going to take anything for granted and not just go through the motions. I never really do that, it just means a lot more to me now knowing that it can be gone tomorrow.&#8221;</p>
<p>&#8220;I think that [Mopar&#8217;s 80th anniversary] speaks for itself. 80 years of Mopar, that&#8217;s just 80 years of horsepower. It&#8217;s pretty cool that everybody&#8217;s so brand-loyal and supported the cause and allowed Mopar to be out here and be able to demonstrate the horsepower like they do on the racetrack. 80 years, that&#8217;s pretty awesome. I think that we have to have a big year for them. We&#8217;ve got to go out here and win a bunch of races and win this championship and make it all happen.</p>
<p><a href="http://dragracecanada.com/mopar-hagan2/"><img class="aligncenter size-full wp-image-25894" src="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Hagan2.jpg" alt="" width="500" height="320" srcset="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Hagan2.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Hagan2-300x192.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Hagan2-400x256.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><br />
<strong>Ron Capps, driver, NAPA Auto Parts Dodge Charger R/T</strong></p>
<p>&#8220;Every time I go to the starting line I know that we sort of have a target on our back with the performance that our team has always put on the racetrack. It&#8217;s funny how you spend the offseason always finding out where you can be better from the previous season. This year was no different. It was great to win a world championship and it&#8217;s another feather in the cap for [crew chief] Rahn Tobler and the crew guys, but we still did the same thing in the off-season. We sat down and figured out how we can be better here, how we can be better there, and Tobler implemented it all winter long. Hopefully we&#8217;ll start off the season in Pomona like we did last year with a win and go on to have a good season.&#8221;</p>
<p><a href="http://dragracecanada.com/mopar-capps/"><img class="aligncenter size-full wp-image-25891" src="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Capps.jpg" alt="" width="500" height="321" srcset="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Capps.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Capps-300x193.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Capps-400x257.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
<p><strong>Jack Beckman, driver, Infinite Hero Dodge Charger R/T</strong></p>
<p>&#8220;Winning so many championships in the recent NHRA tour for Funny Car, I think that says that there&#8217;s a deep level of commitment and excellence, both at Don Schumacher Racing and at Mopar. You know they don&#8217;t just design the body, send us a chunk of carbon and say, &#8216;go race.&#8217; We&#8217;ve got engineering support literally at every race, trying to make what already is arguably the best Funny Car body out here even better. So, I think the philosophy that everybody shares is your best, 100 percent every day, and we never stop trying to get better.&#8221;</p>
<p><a href="http://dragracecanada.com/mopar-jackb/"><img class="aligncenter size-full wp-image-25896" src="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-JackB.jpg" alt="" width="500" height="284" srcset="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-JackB.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-JackB-300x170.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-JackB-400x227.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
<p><strong>Tommy Johnson Jr., driver, Make-A-Wish Dodge Charger R/T</strong></p>
<p>&#8220;I think we&#8217;ve shown over the past three years we&#8217;re very consistent, we&#8217;ve steadily improved and I hope to stay on that track. It isn&#8217;t like we have to go a long ways now. We were just one position out of a championship. To be third and a second, it shows the strength of the team and how methodical they are. I&#8217;m looking forward to this season. I think we&#8217;ve learned from each season and we&#8217;ll take what we&#8217;ve learned and apply it and hopefully move up one more spot.&#8221;</p>
<p><a href="http://dragracecanada.com/80-years-of-mopar-celebration-kickoff/mopar-tj/" rel="attachment wp-att-25900"><img class="aligncenter size-full wp-image-25900" src="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-TJ.jpg" alt="" width="500" height="365" srcset="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-TJ.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-TJ-300x219.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-TJ-377x275.jpg 377w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
<p><strong>Leah Pritchett, driver, Mopar/Pennzoil Top Fuel Dragster</strong></p>
<p>&#8220;The security and sustainability that 2017 brings is remarkable. It&#8217;s actually everything I&#8217;ve dreamed of. Last year I began an official partnership with Mopar and they have been incredible, not only as a sponsor, but as a partner. They do cool things to engage fans with what we&#8217;re doing. Yes, we have the performance part of the house and deliver that on track. But we also get to go into some of their sales conferences and participate in their Block Party in Reading.</p>
<p>&#8220;I&#8217;m extremely pumped for the fact that we get to have a Mopar-primary car again in Reading during the Dodge race. Something really cool that I never thought would happen is being able to have the [Dodge Challenger SRT] Hellcat. I&#8217;ve had a couple different ones and have been able to utilize them in not only different shoots, but really live the power that I get to talk about. I&#8217;ll tell you what, on the street it&#8217;s a beast and on the track we&#8217;re a beast. To go into my second year with Mopar, that&#8217;s been a dream since I got my license with Schumacher Racing in 2008 in a Funny Car. We&#8217;re the epitome of power, and Mopar is the epitome of power.&#8221;</p>
<p><a href="http://dragracecanada.com/mopar-leah1/"><img class="aligncenter size-full wp-image-25897" src="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Leah1.jpg" alt="" width="500" height="365" srcset="http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Leah1.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Leah1-300x219.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/02/Mopar-Leah1-377x275.jpg 377w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
<p><strong>About Mopar Motorsports</strong></p>
<p>The Mopar brand&#8217;s commitment to professional motorsports competition was established in the 1950s when a partnership ignited with drag racing pioneer Don Garlits, resulting in the breaking of numerous speed and performance barriers in HEMI-powered vehicles over the next several decades. In 2016, thanks to Don Schumacher Racing driver Ron Capps, Mopar captured its fourth NHRA Funny Car World Championship in the last six years. As Mopar celebrates 80 years as a brand in 2017, it will focus its NHRA Mello Yello Drag Racing Series efforts on NHRA Funny Car and, with rising star Leah Pritchett, NHRA Top Fuel Dragster. Mopar will also bolster its commitment to NHRA Sportsman racing with new contingency rewards, factory support and at-track technical advice and guidance.</p>
<p><strong>Mopar-First Features</strong></p>
<p>During the brand&#8217;s 80 years, Mopar has introduced numerous industry-first features including:<br />
• Vehicle-information apps: first to introduce smartphone vehicle-information applications, a new channel of communication with consumers<br />
• wiADVISOR: first to incorporate a tablet-based service lane tool<br />
• Electronic Vehicle Tracking System (EVTS): first to market with a new interactive vehicle tracking device that sends owner a text when vehicle is driven too fast or too far based on pre-set parameters<br />
• Wi-Fi: first to offer customers the ability to make their vehicle a wireless hot spot<br />
• Electronic owner manuals: first to introduce traditional owner manuals in a DVD and brief user-guide format</p>
<p><strong>80 Years of Mopar</strong></p>
<p>Mopar (a simple contraction of the words MOtor and PARts) was born on August 1, 1937, as the name of a line of antifreeze products. Mopar has since evolved over 80 years to serve as the total service, parts and customer-care brand of all FCA vehicles around the globe.</p>
<p>Mopar made its mark in the 1960s during the muscle-car era, with Mopar Performance Parts to enhance speed and handling for both road and racing use, and expanded to include technical service and customer support. Today, the Mopar brand&#8217;s global reach distributes more than 500,000 parts and accessories in over 150 markets around the world. With more than 50 parts distribution centers and 25 customer contact centers globally, Mopar integrates service, parts and customer-care operations in order to enhance customer and dealer support worldwide.</p>
<p>For 80 years, Mopar has been the source for genuine parts and accessories for all FCA brands. Mopar parts are engineered together with the same teams that create factory-authorized specifications for FCA vehicles, offering a direct connection that no other aftermarket parts company can provide.</p>
<p style="text-align: center;"><strong>Complete information on the Mopar brand is available at <a href="https://www.mopar.com/en-us.html">www.mopar.com</a> and at <a href="http://www.mopar.ca">www.mopar.ca</a> (in Canada)</strong></p>
<p style="text-align: center;"><strong>Photos by Bruce Biegler</strong></p>
</div>
          	<div class="clr"></div>
          	<span class="linkpages"></span><div class="cleared"></div>
          	
			            
				<div class="roundcornrrbox">
                   	<div class="topleftcorner"><div class="toprightcorner"></div></div>
                    <div class="roubcornrcontent">
            			<span class="posttags-single">No tags</span>
                    	<div class="clr"></div>
                    </div>
                    <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
                </div>                        
                        
			
			        	
            <div class="clr"></div>
        </div> <!-- Closes topPost -->
		<small></small>

		<div id="comments">
			            <!-- WP 2.7 and above -->
                        
                    </div> <!-- Closes Comment -->

<div id="extrastuff">
<span id="rssleft"><a href="http://dragracecanada.com/80-years-of-mopar-celebration-kickoff/feed/"><abbr title="Really Simple Syndication">RSS</abbr> feed for this post (comments)</a></span>

<span id="trackright"></span>
<div class="cleared"></div>
</div>


<br><div align="center"><a href="http://www.arp-bolts.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/ARP_DRC_570x70_animated.gif" border="0"></a></div><br>
</div><!-- Closes Main -->


<div id="rightcol">
	<div class="roundcornrrbox">
    <div class="topleftcorner"><div class="toprightcorner"></div></div>
    <div class="roundcrrcnt">
    

        	<div id="searchboxo">
        		<form method="get" id="searchform" action="http://dragracecanada.com/">
    <input type="text" value="Search DragRaceCanada" name="s" id="searchbox" onfocus="this.value=''" class="searchinput"/>
    <input type="submit" class="submitbutton" value="Search" />
</form> 
        </div>

        <!-- widget -->
                    <div class="widget-cat">
                <h4>Categories</h4>
                <ul>
                    	<li class="cat-item cat-item-13"><a href="http://dragracecanada.com/category/editors-extra/" >Editor&#039;s Extra</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://dragracecanada.com/category/hotzone/" >Hotzone</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://dragracecanada.com/category/international-dateline/" >Int&#039;l Dateline</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://dragracecanada.com/category/national-news/" >National News</a>
</li>
	<li class="cat-item cat-item-9"><a href="http://dragracecanada.com/category/northern-exposure/" >Northern Exposure</a>
</li>
	<li class="cat-item cat-item-10"><a href="http://dragracecanada.com/category/performance-pipeline/" >Perf. Pipeline</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://dragracecanada.com/category/photo-gallery/" >Photo Gallery</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://dragracecanada.com/category/the-pro-mod-portal/" >PM Portal</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://dragracecanada.com/category/uncategorized/" >Uncategorized</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://dragracecanada.com/category/team-blogs/" title="Team Blogs">Your Race Team</a>
</li>
                </ul>
            </div>

<div align="center"><img src="http://dragracecanada.com/wp-content/uploads/2013/04/mopar_national_news.gif" border="0" vspace="4"><br><br></div>

         

        <br><div align="center"><script type="text/javascript"><!--
google_ad_client = "pub-9456405457314885";
google_ad_width = 120;
google_ad_height = 600;
google_ad_format = "120x600_as";
google_ad_channel ="";
google_color_border = "666666";
google_color_bg = "000000";
google_color_link = "FFFFFF";
google_color_url = "FF0000";
google_color_text = "FF0000";
//--></script>
<script type="text/javascript"
  src="http://pagead2.googlesyndication.com/pagead/show_ads.js"> 
</script></div><br>        <div align="center">        
            <a href="http://dragracecanada.com">
                <img src="http://www.dragracecanada.com/images/drc_wordpress_returnhome.gif" width="250" height="129" vspace="2" alt="DragRaceCanada.com" />
            </a>
        </div>


        <div class="clr"></div>
    </div>
    <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
</div>
</div>
<div class="clr"></div>




    <div id="dhtmlgoodies_slideshow">
	<div id="galleryContainer" align="center">
		<div id="arrow_left"><img src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/img/arrow_left.gif"></div>
		<div id="arrow_right"><img src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/img/arrow_right.gif"></div>
		<div id="theImages">
				<!-- Thumbnails -->
			<a href="http://www.mopar.com" target="_blank"><img src="http://www.dragracecanada.com/images/wordpress/mopar_chain.jpg"></a>
			<a href="http://www.lucasoil.ca" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2015/05/lucasoil_lg.gif"></a>
			<a href="http://www.vpracingfuels.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2014/05/vp_2014.gif"></a>
			<a href="http://www.castrolraceway.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2011/08/castrol_raceway.gif"></a>
			<a href="http://www.joestransmission.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/02/joestransmission.gif"></a>
			<a href="http://fasteddieracewear.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/fasteddie_logo_2016.gif"></a>
			<a href="http://www.tracklessvehicles.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2014/08/Trackless_182x70.gif"></a>
			<a href="http://www.nitromoose.net" target="_blank"><img src="http://www.dragracecanada.com/images/nitromoose.gif"></a>
			<a href="http://www.enationalperformance.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/NPW.png"></a>
			<a href="http://www.karbelt.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/Karbelt.png"></a>
			<a href="http://www.partspro.ca/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/PartsPro-CA.png"></a>
			<a href="http://www.acemfg.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/05/ace_mfg_152x70.gif"></a>
			<a href="http://www.boychuk.net/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2010/09/Boychuk182x70.gif"></a>
			<a href="http://www.artcal.com" target="_blank"><img src="http://www.dragracecanada.com/graphics/artcal.gif"></a>
			<a href="http://www.joestransmission.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/03/boniferro_185x70"></a>
			<a href="http://www.mellingselectperformance.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/mel.png"></a>
			<a href="http://www.arp-bolts.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/arp_190x70.gif"></a>
			<a href="https://www.flex-a-lite.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/flexalite_112x67.gif"></a>				<a href="http://www.OconnorRV.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/oconner_142x70.gif"></a>			<!-- End thumbnails -->
				
				<div id="slideEnd"></div>
		</div>
	</div>
</div>
	<div id="bottompanel">
    <div class="roundcornrrbox">
        <div class="topleftcorner"><div class="toprightcorner"></div></div>
        <div class="roundcrrcnt">
        
        	
            <div class="col1">
                
					                    <h3>Recent Posts</h3>
                    <ul>
                                                    <li>
                                <a href="http://dragracecanada.com/80-years-of-mopar-celebration-kickoff/">80 Years of Mopar Celebration Kickoff </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/2017-nhra-schedule/">2017 NHRA Schedule </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/some-progressive-girl-trouble/">Some Progressive Girl Trouble </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/big-tent-announcement/">&#8220;Big Tent&#8221; Announcement </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/nhra-lucas-oil-on-the-telly/">NHRA Lucas Oil Racing &#8220;on the telly&#8221; </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/ihraespn-deal-fuels-optimism/">IHRA/ESPN Deal Fuels Optimism </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/breaking-news-2017-mopar-canadian-nationals-details/">Breaking News: 2017 Mopar Canadian Nationals &#8211; Details! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/manitoba-master-craft/">Manitoba Master-craft! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/canadian-black-art-pioneers/">Canadian “Black Art” Pioneers </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/more-muscle-added-to-nmca/">More Muscle Added to NMCA </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/a-bulldoggers-braintrust/">A Bulldogger’s Braintrust </a>
                            </li>
                        			
                    </ul>
                    

                            </div>
            
            <div class="col2">
                      
                    <h3>Archives</h3>
                    <ul>
                        	<li><a href='http://dragracecanada.com/2017/02/'>February 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/01/'>January 2017</a></li>
	<li><a href='http://dragracecanada.com/2016/12/'>December 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/11/'>November 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/10/'>October 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/09/'>September 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/08/'>August 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/07/'>July 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/06/'>June 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/05/'>May 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/04/'>April 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/03/'>March 2016</a></li>
                    </ul>

                            </div>
            
            <div class="clr"></div>
        

            <div class="clr"></div>
        </div>
        <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
    </div>
</div>
<!-- Bottom Panel ends -->


	
    <div class="copyr">Copyright &copy; 1996-2016 DragRaceCanada.com. All rights reserved.</div>    
    <div class="clr16"></div>
	</div>
    <div id="layoutbottom"></div>
</div>

<div id="credit" align="center">
	<abbr title="Jarrah/1.7">Jarrah</abbr> theme by <a href="http://www.templatesnext.org/">Templates Next</a> 
    | Powered by <a href="http://wordpress.org/">WordPress</a> 
</div>

	<div style="display:none">
	</div>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201706'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201706.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.0.3',blog:'26164618',post:'25899',tz:'-7',srv:'dragracecanada.com'} ]);
	_stq.push([ 'clickTrackerInit', '26164618', '25899' ]);
</script>

</body>
</html>