<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"  />
<title>Western Doorwarz Continuum! &laquo;  DragRaceCanada.com</title>
<meta name="generator" content="WordPress 4.7.5" />
<meta name="robots" content="follow, all" />

<link rel="shortcut icon" href="http://dragracecanada.com/wp-content/themes/jarrah/favicon.ico" />
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="DragRaceCanada.com RSS Feed" href="http://dragracecanada.com/feed/" />
<link rel="pingback" href="http://dragracecanada.com/xmlrpc.php" />
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/css/menu.css" type="text/css" media="screen" />
<!--[if IE]><link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/css/ie.css" type="text/css" media="screen" /><![endif]-->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/dragracecanada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='http://dragracecanada.com/wp-content/plugins/ditty-news-ticker/assets/fontastic/styles.css?ver=2.0.15' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='http://dragracecanada.com/wp-content/plugins/ditty-news-ticker/assets/css/style.css?ver=2.0.15' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='http://dragracecanada.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://dragracecanada.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.0.3' type='text/css' media='all' />
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/flash-album-gallery/admin/js/swfobject.js?ver=2.2'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/flash-album-gallery/admin/js/swfaddress.js?ver=2.4'></script>
<link rel='https://api.w.org/' href='http://dragracecanada.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://dragracecanada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://dragracecanada.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='USDS Take Two &#8211; Takeaway!' href='http://dragracecanada.com/usds-take-two-takeaway/' />
<meta name="generator" content="WordPress 4.7.5" />
<link rel="canonical" href="http://dragracecanada.com/western-doorwarz-continuum/" />
<link rel='shortlink' href='http://wp.me/p1LMBY-7cr' />
<link rel="alternate" type="application/json+oembed" href="http://dragracecanada.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragracecanada.com%2Fwestern-doorwarz-continuum%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://dragracecanada.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragracecanada.com%2Fwestern-doorwarz-continuum%2F&#038;format=xml" />
<script type='text/javascript'>AC_FL_RunContent = 0;</script><script type='text/javascript' src="http://dragracecanada.com/wp-content/plugins/dynamic-headers/AC_RunActiveContent.js"></script><link rel="stylesheet" href="http://dragracecanada.com/wp-content/plugins/logo-slideshow/css/image-slideshow.css" type="text/css" media="screen" charset="utf-8"/>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/image-slideshow.js"></script>
	
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/plugins/wp-photo-album/theme/wppa_style.css" type="text/css" media="screen" />
		
<!-- <meta name='Grand Flagallery' content='4.41' /> -->

<link rel='dns-prefetch' href='//v0.wordpress.com'>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Western Doorwarz Continuum!" />
<meta property="og:url" content="http://dragracecanada.com/western-doorwarz-continuum/" />
<meta property="og:description" content="Super scenic Mission Raceway played host to it&#8217;s 5th edition annual Doorwarz event last weekend&#8230;.." />
<meta property="article:published_time" content="2017-07-07T19:00:20+00:00" />
<meta property="article:modified_time" content="2017-07-05T14:50:48+00:00" />
<meta property="og:site_name" content="DragRaceCanada.com" />
<meta property="og:image" content="http://dragracecanada.com/wp-content/uploads/2017/07/Mission-Doorwarz-400.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="250" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://dragracecanada.com/wp-content/uploads/2017/07/Mission-Doorwarz-400.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.pngFix.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.easing.min.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.lavalamp.min.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/my-menu.js"></script>

<!-- this product is released under General Public License. Please see the attached file for details. You can also find details about the license at http://www.opensource.org/licenses/gpl-license.php -->
<script type="text/javascript">
/* <![CDATA[ */

jQuery(document).ready(function(){ 
    jQuery(document).pngFix(); 
});

/* ]]> */ 
</script>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21904869-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<style type="text/css">

/* banner rotator styles */
div#banner_rotator  {
    width:960px; height:80px;
    padding:0px;
    background-color:#000;
}

div#banner_rotator span {
    display: block; text-align: center;
}

div#banner_rotator a:link,
div#banner_rotator a:visited, 
div#banner_rotator a:hover {
    color:#0F2F8D;
    text-decoration:none;
}

</style>

<script src="http://www.dragracecanada.com/js/dw_rotate_banner.js" type="text/javascript"></script>
<script type="text/javascript">

DYN_WEB.Event.domReady( function() {
    
    var banner = {
        id: 'banner_rotator', // id of element that displays rotating content
        speed: 6000, // default 4500
        bPause: false, // pause/resume onmouseover/out
        // banner content goes here
        // commas separate items, but no comma after last item
        content: ['<a href="http://www.mopar.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2016/12/high-performance-1.jpg" border="0"></span></a>',
            '<a href="http://www.lucasoil.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LucasOil-banner-2017.jpg" border="0"></span></a>',
	    '<a href="http://www.loudmusicloudcars.com/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LMLC-960X80-1.jpg" border="0"></span></a>'
        ]
    };
    
    new DYN_WEB.Banner_Rotator(banner);
    
});

</script>
</head>

<body>

<div id="wrapper" align="center">
	<div id="layouttop"></div>
    
    <!-- Header Starts -->
    <div id="header" align="center">
	<a href="http://www.dragracecanada.com/">
	    <img src="http://dragracecanada.com/wp-content/uploads/2014/12/DRC_Logo_trans.png" border="0">
	</a>
	<SPAN STYLE="font-family: Arial; font-size: 16px; font-decoration: bold; font-style: italic ; color: #FFFFFF"><br>proudly presented by:&nbsp;&nbsp;</SPAN>
	<br>
	<br>
	<div id="banner_rotator"><a href="http://www.lucasoil.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LucasOil-banner-2017.jpg" border="0"></span></a></div>
    	<!-- 				<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="990" height="150" id="mediaHeader" align="middle">
				<param name="allowScriptAccess" value="sameDomain" />
				<param name="allowFullScreen" value="false" />
				<param name="wmode" value="transparent" />
				<param name="movie" value="http://dragracecanada.com/wp-content/header-images/DRC2013.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" />	
				<embed src="http://dragracecanada.com/wp-content/header-images/DRC2013.swf" wmode="transparent" quality="high" bgcolor="#ffffff" width="990" height="150" name="mediaHeader" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
				</object>
		 -->        
    </div>
    <!-- Header Ends -->

    <div id="innerwrapper">

    	
        <!-- Main nav Starts here -->
<!--
        <div id="navouter">
            <div id="nav">

<ul class="lavalamp" id="menu1">  
<li class="page_item "><a href="http://dragracecanada.com">Home</a></li> 
		<li class="cat-item cat-item-10"><a href="http://dragracecanada.com/category/performance-pipeline/" >BWD Performance Pipeline</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://dragracecanada.com/category/editors-extra/" >Editor&#039;s Extra</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://dragracecanada.com/category/hoctcars-hottopics/" >Hot Cars Hot Topics</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://dragracecanada.com/category/international-dateline/" >International Dateline</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://dragracecanada.com/category/hotzone/" >Lucas Oil Hotzone</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://dragracecanada.com/category/national-news/" >Mopar Canada &#8211; National News</a>
</li>
	<li class="cat-item cat-item-9"><a href="http://dragracecanada.com/category/northern-exposure/" >Northern Exposure</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://dragracecanada.com/category/team-blogs/" title="Team Blogs">Paton Racing Blog</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://dragracecanada.com/category/photo-gallery/" >Photo Gallery</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://dragracecanada.com/category/the-pro-mod-portal/" >VP Racing Pro Mod Portal</a>
</li>
		 	
</ul> 
          
            </div>
        </div>
 //-->
        <!-- Main nav Ends -->
<div id="maincol">

<br><div align="center"><a href="http://www.oconnorrv.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/04/northern_exposure_oconner.png" border="0"></a></div><br>
		
        <div class="postwrap">
          	<h2 class="posttitle"><a href="http://dragracecanada.com/western-doorwarz-continuum/">Western Doorwarz Continuum!</a></h2>
          	<div class="postmeta">by <a href="http://dragracecanada.com/author/editor/" title="Posts by editor" rel="author">editor</a> on Jul.07, 2017, under <a href="http://dragracecanada.com/category/northern-exposure/" rel="category tag">Northern Exposure</a></div>
            <div class="clr16"></div>
          	<div class="postcontent"><p><em>Super scenic Mission Raceway played host to it&#8217;s 5th edition annual Doorwarz event last weekend&#8230;..</em><span id="more-27679"></span></p>
<p>It was again &#8220;Doorwarz  drama&#8221; as Mission Raceway Park featured, as before, the best and fastest door cars in the West.</p>
<p>A great field of cars and class categories were, led by the Belair Power Pro Mods of the Western Drag Racing League. The expected group of B.C. and Alberta racers, minus Joe Delehay (nursing a hockey injury) and Glen Kerunsky (crashed new car in testing) were joined by two more very fast cars that figured prominently in the weekend&#8217;s racing.</p>
<p>Mike Gondziola came out from Saskatoon again with his nitrous Corvette, his first race since Doorwarz last year, and most figured him to be the one to beat, at least in the Low ET department. But, in a surprise move that was only clear to all when they pulled in to the track, the decision was made by the Molinari-Bond team to tow out from the last NHRA race in Ohio (which they won) with their Turbo Firebird, to compete in their &#8216;home&#8217; race, with Justin Bond and many of the sponsors including RAD being from the Fraser Valley.</p>
<p>On Friday evening in qualifying, Shane Molinari and Gonzi laid down 5.79s to easily lead the field and establish who would be the ones to beat. Come Saturday night, the weather was again ideal (high teens, no humidity, perfect sea level Mission conditions), and the quick cars were quick again. Gonzi ran early-shut off 5.89 and 5.88 runs (since he felt he couldn&#8217;t improve on the 5.79), series regular Garrett Richards ran his quickest of the weekend, a 5.91 in his screw-blown Mustang, and Paul Glandon turned his first &#8216;five&#8217; in Canada, a 5.99, in his turbo Camaro. Meanwhile, Molinari fired the definitive shot, with a 5.77 / 258 for Low ET and Top Speed of the Meet.</p>
<div id="attachment_27675" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/17-mission-promod-molinarix/"><img class="size-full wp-image-27675" src="http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-ProMod-Molinarix.jpg" alt="" width="500" height="202" srcset="http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-ProMod-Molinarix.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-ProMod-Molinarix-300x121.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-ProMod-Molinarix-400x162.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Recent NHRA Norwalk winner Shane Molinari set both low ET/top MPH racing the RAD Torque Systems backed &#8220;Turbo-bird&#8221;</p></div>
<p>The first round Sunday saw the quick four cars from qualifying all essentially repeating and winning their races, while the best of the rest was Wade Sjostrom of Edmonton, who has stepped up his game, with a 6.21 from his blown &#8217;57 Chevy.</p>
<p>Round Two saw the big four advance again, with Molinari singling to a shaky shut-off run, and the others having to work for it. Gonzi beat the quicker-leaving local runner Jay Syvertsen, who seems to have found some consistency, 5.93 to 6.21, Sjostrom improved again to a career-best 6.16 but Glandon beat him with a 6.02 / 250, and Richards kept in the 5.90 zone with a 5.98-6.18 defeat of Kelowna&#8217;s Kerry Stone.</p>
<p>The semis, then, had the quickest four cars, as it should be, and in the heat (mid-20s) of the day, all laid down fives. Richards grabbed a 0.55 advantage on the tree, and needed all of it to beat Gondziola by 0.003 seconds, 5.97-5.92, while Molinari had a half-car-length lead by the tree, and handily beat Glandon&#8217;s good and consistent 5.99 / 250 with a 5.89 / 256.</p>
<p>So, on paper, the consistent 5.80s car should have beaten the consistent 5.90s car in the finals, but Richards had other ideas. He did his part with an other-worldly .011 light (with a pedal clutch, no less) for a .052 head start, and ran his quickest of the day, a 5.93, while Molinari fell off to his slowest complete run of the day, a 5.92. The blown Mustang was the winner, and the two Washington-state drivers put on a heck of a race.</p>
<div id="attachment_27676" style="width: 509px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/17-mission-promod-semi-richardsgonzix/"><img class="size-full wp-image-27676" src="http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-ProMod-Semi-RichardsGonzix.jpg" alt="" width="499" height="265" srcset="http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-ProMod-Semi-RichardsGonzix.jpg 499w, http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-ProMod-Semi-RichardsGonzix-300x159.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-ProMod-Semi-RichardsGonzix-400x212.jpg 400w" sizes="(max-width: 499px) 100vw, 499px" /></a><p class="wp-caption-text">Washington state&#8217;s Garrett Richards (near lane) continued his domination of WDRL Pro Mod racing.</p></div>
<p>For a few years now, Ken Sihota from Langley, and Oregon&#8217;s Paja Agatonovic have been the two to beat in Outlaw 10.5, and that continued this time around. They were one-two in qualifying (4.18, 4.26) and each ran in the teens in elims, so to see them in the final was expected. Unfortunately, though, Sihota had electrical gremlins and the car went nowhere fast at the hit, while Agatonovic motored through to a 4.16 / 179 pass to win.</p>
<div id="attachment_27678" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/17-mission-outlaw10-5-sihota-agatonovicx/"><img class="size-full wp-image-27678" src="http://dragracecanada.com/wp-content/uploads/2017/07/Dorrwarz-17-Mission-Outlaw10.5-Sihota-AgatonovicX.jpg" alt="" width="500" height="312" srcset="http://dragracecanada.com/wp-content/uploads/2017/07/Dorrwarz-17-Mission-Outlaw10.5-Sihota-AgatonovicX.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/07/Dorrwarz-17-Mission-Outlaw10.5-Sihota-AgatonovicX-300x187.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/07/Dorrwarz-17-Mission-Outlaw10.5-Sihota-AgatonovicX-400x250.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Pacific Northwest powers &#8212; Ken Sihota and Paja Agatonovic faced off for the Outlaw 10.5 title.</p></div>
<p>RH Race Cars Top Sportsman, as usual, ran a race each day, and Darren Williams took both trophies home to Calgary, driving his Dodge Avenger to wins over both John De Jonge and James Rutherford.</p>
<div id="attachment_27677" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/17-mission-top-sportsman-williamsrutherfordx/"><img class="size-full wp-image-27677" src="http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-Top-Sportsman-WilliamsRutherfordx.jpg" alt="" width="500" height="249" srcset="http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-Top-Sportsman-WilliamsRutherfordx.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-Top-Sportsman-WilliamsRutherfordx-300x149.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-Top-Sportsman-WilliamsRutherfordx-400x199.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Racing his Dodge Avenger &#8211; Calgary&#8217;s Darren Williams (near lane) collected two event TS titles.</p></div>
<p style="text-align: center;">Other winners included:</p>
<p style="text-align: center;">Outlaw 275 – Jordie Lazic, Kelowna, 4.83 def. Steve Skokin, Surrey, 4.90.</p>
<p style="text-align: center;">Canada West Doorslammers – Paul Dupree Jr. def. Grant Howell.</p>
<p style="text-align: center;">Top Street 604 – Jay Graw, Abbotsford def. Reece Lindgren, Maple Ridge.</p>
<div id="attachment_27674" style="width: 509px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/17-mission-outlaw-275-final-skokinlazic-photo-by-robert-hunterx/"><img class="size-full wp-image-27674" src="http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-Outlaw-275-Final-SkokinLazic-PHOTO-BY-ROBERT-HUNTERx.jpg" alt="" width="499" height="257" srcset="http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-Outlaw-275-Final-SkokinLazic-PHOTO-BY-ROBERT-HUNTERx.jpg 499w, http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-Outlaw-275-Final-SkokinLazic-PHOTO-BY-ROBERT-HUNTERx-300x155.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-Outlaw-275-Final-SkokinLazic-PHOTO-BY-ROBERT-HUNTERx-400x206.jpg 400w" sizes="(max-width: 499px) 100vw, 499px" /></a><p class="wp-caption-text">The Outlaw 275 final featured Steve Skokin&#8217;s Mustang versus Jordie Lazic&#8217;s Nova</p></div>
<div id="attachment_27673" style="width: 509px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/17-mission-doorslammers-dupreehowellx/"><img class="size-full wp-image-27673" src="http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-Doorslammers-DupreeHowellx.jpg" alt="" width="499" height="262" srcset="http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-Doorslammers-DupreeHowellx.jpg 499w, http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-Doorslammers-DupreeHowellx-300x158.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/07/Doorwarz-17-Mission-Doorslammers-DupreeHowellx-400x210.jpg 400w" sizes="(max-width: 499px) 100vw, 499px" /></a><p class="wp-caption-text">Paul Dupree raced Grant Howell in Mission Raceway&#8217;s homegrown &#8220;Canada West Doorslammers&#8221; class category finale.</p></div>
<p style="text-align: center;"><strong>From the Pro Mod Notebook:</strong></p>
<p>Dale Petersen (turbo Monte Carlo, Dawson Creek, BC) and Keith Korecki (nitrous Shelby Mustang, Kelowna) both qualified, although not up to their usual performance levels, but could not make the call for Round One, due to damage.</p>
<p>Paul Glandon and Wade Sjostrom were two happy Alberta racers, with Paul running consistent low sixes plus two 5.99s at 250 mph, while Wade ran deep in the sixes including a personal best of 6.16. Also running well was Regina&#8217;s Dan Vogt with 864-inch Sonny&#8217;s power, with a 6.26 in qualifying, but he couldn&#8217;t hold it on the line in Round One, and fouled in a big way.</p>
<div id="attachment_27681" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/mission-glandon/"><img class="size-full wp-image-27681" src="http://dragracecanada.com/wp-content/uploads/2017/07/Mission-Glandon.jpg" alt="" width="500" height="247" srcset="http://dragracecanada.com/wp-content/uploads/2017/07/Mission-Glandon.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/07/Mission-Glandon-300x148.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/07/Mission-Glandon-400x198.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Racing his turbocharged Camaro &#8212; Paul Glandon had an inspiring event effort&#8230;.</p></div>
<p>Not so happy was Calgary&#8217;s Rick DiStefano, who spent last season trying to dial in his turbo &#8217;70 Camaro, and then got an entirely new car for this year that looks identical to the last one. Once again, he is trying to get this one to run full passes, citing control of turbo boost as the main issue, and in qualifying, the best he could manage was an 8.41. The last run Saturday night was encouraging, looking strong to the eighth-mile, but then he had to back off with problems. Last place on the qualifying sheet got him a run against Molinari in Round One. The good news is that he ran a pedalled 6.36 / 239, but reportedly hurt the engine in the process.</p>
<p style="text-align: center;"><em>Posted by Gerry Frechette</em></p>
<p style="text-align: center;"><em>Photos by Gerry Frechtte &amp; Robert Hunter</em></p>
</div>
          	<div class="clr"></div>
          	<span class="linkpages"></span><div class="cleared"></div>
          	
			            
				<div class="roundcornrrbox">
                   	<div class="topleftcorner"><div class="toprightcorner"></div></div>
                    <div class="roubcornrcontent">
            			<span class="posttags-single">No tags</span>
                    	<div class="clr"></div>
                    </div>
                    <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
                </div>                        
                        
			
			        	
            <div class="clr"></div>
        </div> <!-- Closes topPost -->
		<small></small>

		<div id="comments">
			            <!-- WP 2.7 and above -->
                        
                    </div> <!-- Closes Comment -->

<div id="extrastuff">
<span id="rssleft"><a href="http://dragracecanada.com/western-doorwarz-continuum/feed/"><abbr title="Really Simple Syndication">RSS</abbr> feed for this post (comments)</a></span>

<span id="trackright"></span>
<div class="cleared"></div>
</div>


<br><div align="center"><a href="http://partspro.ca/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/PartsPro-570-1.png" border="0"></a></div><br>
</div><!-- Closes Main -->


<div id="rightcol">
	<div class="roundcornrrbox">
    <div class="topleftcorner"><div class="toprightcorner"></div></div>
    <div class="roundcrrcnt">
    

        	<div id="searchboxo">
        		<form method="get" id="searchform" action="http://dragracecanada.com/">
    <input type="text" value="Search DragRaceCanada" name="s" id="searchbox" onfocus="this.value=''" class="searchinput"/>
    <input type="submit" class="submitbutton" value="Search" />
</form> 
        </div>

        <!-- widget -->
                    <div class="widget-cat">
                <h4>Categories</h4>
                <ul>
                    	<li class="cat-item cat-item-10"><a href="http://dragracecanada.com/category/performance-pipeline/" >BWD Performance Pipeline</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://dragracecanada.com/category/editors-extra/" >Editor&#039;s Extra</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://dragracecanada.com/category/hoctcars-hottopics/" >Hot Cars Hot Topics</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://dragracecanada.com/category/international-dateline/" >International Dateline</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://dragracecanada.com/category/hotzone/" >Lucas Oil Hotzone</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://dragracecanada.com/category/national-news/" >Mopar Canada &#8211; National News</a>
</li>
	<li class="cat-item cat-item-9"><a href="http://dragracecanada.com/category/northern-exposure/" >Northern Exposure</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://dragracecanada.com/category/team-blogs/" title="Team Blogs">Paton Racing Blog</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://dragracecanada.com/category/photo-gallery/" >Photo Gallery</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://dragracecanada.com/category/the-pro-mod-portal/" >VP Racing Pro Mod Portal</a>
</li>
                </ul>
            </div>

<div align="center"><img src="http://dragracecanada.com/wp-content/uploads/2013/04/mopar_national_news.gif" border="0" vspace="4"><br><br></div>

         

        <br><div align="center"><script type="text/javascript"><!--
google_ad_client = "pub-9456405457314885";
google_ad_width = 120;
google_ad_height = 600;
google_ad_format = "120x600_as";
google_ad_channel ="";
google_color_border = "666666";
google_color_bg = "000000";
google_color_link = "FFFFFF";
google_color_url = "FF0000";
google_color_text = "FF0000";
//--></script>
<script type="text/javascript"
  src="http://pagead2.googlesyndication.com/pagead/show_ads.js"> 
</script></div><br>        <div align="center">        
            <a href="http://dragracecanada.com">
                <img src="http://www.dragracecanada.com/images/drc_wordpress_returnhome.gif" width="250" height="129" vspace="2" alt="DragRaceCanada.com" />
            </a>
        </div>


        <div class="clr"></div>
    </div>
    <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
</div>
</div>
<div class="clr"></div>




    <div id="dhtmlgoodies_slideshow">
	<div id="galleryContainer" align="center">
		<div id="arrow_left"><img src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/img/arrow_left.gif"></div>
		<div id="arrow_right"><img src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/img/arrow_right.gif"></div>
		<div id="theImages">
				<!-- Thumbnails -->
			<a href="http://www.mopar.com" target="_blank"><img src="http://www.dragracecanada.com/images/wordpress/mopar_chain.jpg"></a>
			<a href="http://www.lucasoil.ca" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2015/05/lucasoil_lg.gif"></a>
			<a href="http://www.vpracingfuels.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2014/05/vp_2014.gif"></a>
			<a href="http://www.castrolraceway.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2011/08/castrol_raceway.gif"></a>
			<a href="http://www.joestransmission.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/02/joestransmission.gif"></a>
			<a href="http://fasteddieracewear.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/fasteddie_logo_2016.gif"></a>
			<a href="http://www.tracklessvehicles.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2014/08/Trackless_182x70.gif"></a>
			<a href="http://www.bigwestdodge.ca" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/03/bigwestdodge_th.jpg"></a>
			<a href="http://www.enationalperformance.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/NPW.png"></a>
			<a href="http://www.karbelt.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/Karbelt.png"></a>
			<a href="http://www.partspro.ca/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/PartsPro-CA.png"></a>
			<a href="http://www.acemfg.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/05/ace_mfg_152x70.gif"></a>
			<a href="http://www.boychuk.net/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2010/09/Boychuk182x70.gif"></a>
			<a href="http://www.artcal.com" target="_blank"><img src="http://www.dragracecanada.com/graphics/artcal.gif"></a>
			<a href="http://www.joestransmission.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/03/boniferro_185x70"></a>
			<a href="http://www.mellingselectperformance.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/mel.png"></a>
			<a href="http://www.arp-bolts.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/arp_190x70.gif"></a>
			<a href="https://www.flex-a-lite.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/flexalite_112x67.gif"></a>
			<a href="http://www.OconnorRV.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/oconner_142x70.gif"></a>
			<a href="http://www.energysuspension.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/03/ene.png"></a>			<!-- End thumbnails -->
				
				<div id="slideEnd"></div>
		</div>
	</div>
</div>
	<div id="bottompanel">
    <div class="roundcornrrbox">
        <div class="topleftcorner"><div class="toprightcorner"></div></div>
        <div class="roundcrrcnt">
        
        	
            <div class="col1">
                
					                    <h3>Recent Posts</h3>
                    <ul>
                                                    <li>
                                <a href="http://dragracecanada.com/western-doorwarz-continuum/">Western Doorwarz Continuum! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/usds-take-two-takeaway/">USDS Take Two &#8211; Takeaway! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/exciting-eighth-effort/">Exciting Eighth Effort! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/2017-pro-mod-schedule/">2017 Pro Mod Schedule </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/finally-for-fast-car/">Finally &#8211; For Fast Car! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/hot-cars-hot-topics-14/">Hot Cars &#8211; Hot Topics </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/2017-nhra-schedule/">2017 NHRA Schedule </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/more-norwalk-notoriety/">More Norwalk Notoriety! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/retrabution-reset-weekend/">Retribution &#038; Reset Weekend! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/give-me-fuel-give-me-fire/">Give Me Fuel….Give Me Fire….. </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/finally-for-fan-favourite/">Finally &#8212; for Fan Favourite! </a>
                            </li>
                        			
                    </ul>
                    

                            </div>
            
            <div class="col2">
                      
                    <h3>Archives</h3>
                    <ul>
                        	<li><a href='http://dragracecanada.com/2017/07/'>July 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/06/'>June 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/05/'>May 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/04/'>April 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/03/'>March 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/02/'>February 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/01/'>January 2017</a></li>
	<li><a href='http://dragracecanada.com/2016/12/'>December 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/11/'>November 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/10/'>October 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/09/'>September 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/08/'>August 2016</a></li>
                    </ul>

                            </div>
            
            <div class="clr"></div>
        

            <div class="clr"></div>
        </div>
        <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
    </div>
</div>
<!-- Bottom Panel ends -->


	
    <div class="copyr">Copyright &copy; 1996-2017 DragRaceCanada.com. All rights reserved.</div>    
    <div class="clr16"></div>
	</div>
    <div id="layoutbottom"></div>
</div>

<div id="credit" align="center">
	<abbr title="Jarrah/1.7">Jarrah</abbr> theme by <a href="http://www.templatesnext.org/">Templates Next</a> 
    | Powered by <a href="http://wordpress.org/">WordPress</a> 
</div>
	<div style="display:none">
	</div>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201727'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Julaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201727.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.0.3',blog:'26164618',post:'27679',tz:'-7',srv:'dragracecanada.com'} ]);
	_stq.push([ 'clickTrackerInit', '26164618', '27679' ]);
</script>

</body>
</html>