<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"  />
<title>Record Pace @ PDRA Round One! &laquo;  DragRaceCanada.com</title>
<meta name="generator" content="WordPress 4.7.3" />
<meta name="robots" content="follow, all" />

<link rel="shortcut icon" href="http://dragracecanada.com/wp-content/themes/jarrah/favicon.ico" />
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="DragRaceCanada.com RSS Feed" href="http://dragracecanada.com/feed/" />
<link rel="pingback" href="http://dragracecanada.com/xmlrpc.php" />
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/css/menu.css" type="text/css" media="screen" />
<!--[if IE]><link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/css/ie.css" type="text/css" media="screen" /><![endif]-->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/dragracecanada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='http://dragracecanada.com/wp-content/plugins/ditty-news-ticker/assets/fontastic/styles.css?ver=2.0.15' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='http://dragracecanada.com/wp-content/plugins/ditty-news-ticker/assets/css/style.css?ver=2.0.15' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='http://dragracecanada.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://dragracecanada.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.0.3' type='text/css' media='all' />
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/flash-album-gallery/admin/js/swfobject.js?ver=2.2'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/flash-album-gallery/admin/js/swfaddress.js?ver=2.4'></script>
<link rel='https://api.w.org/' href='http://dragracecanada.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://dragracecanada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://dragracecanada.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Toronto&#8217;s Motorama &#8211; Photo Highlights' href='http://dragracecanada.com/torontos-motorama-photo-highlights/' />
<link rel='next' title='2017 Pro Mod Schedule' href='http://dragracecanada.com/2017-pro-mod-schedule/' />
<meta name="generator" content="WordPress 4.7.3" />
<link rel="canonical" href="http://dragracecanada.com/record-pace-pdra-round-one/" />
<link rel='shortlink' href='http://wp.me/p1LMBY-6Rt' />
<link rel="alternate" type="application/json+oembed" href="http://dragracecanada.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragracecanada.com%2Frecord-pace-pdra-round-one%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://dragracecanada.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragracecanada.com%2Frecord-pace-pdra-round-one%2F&#038;format=xml" />
<script type='text/javascript'>AC_FL_RunContent = 0;</script><script type='text/javascript' src="http://dragracecanada.com/wp-content/plugins/dynamic-headers/AC_RunActiveContent.js"></script><link rel="stylesheet" href="http://dragracecanada.com/wp-content/plugins/logo-slideshow/css/image-slideshow.css" type="text/css" media="screen" charset="utf-8"/>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/image-slideshow.js"></script>
	
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/plugins/wp-photo-album/theme/wppa_style.css" type="text/css" media="screen" />
		
<!-- <meta name='Grand Flagallery' content='4.41' /> -->

<link rel='dns-prefetch' href='//v0.wordpress.com'>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Record Pace @ PDRA Round One!" />
<meta property="og:url" content="http://dragracecanada.com/record-pace-pdra-round-one/" />
<meta property="og:description" content="Drag Racing’s marquee 1/8th mile circuit opened for season business in South Georgia last weekend…" />
<meta property="article:published_time" content="2017-03-13T14:32:20+00:00" />
<meta property="article:modified_time" content="2017-03-13T14:37:39+00:00" />
<meta property="og:site_name" content="DragRaceCanada.com" />
<meta property="og:image" content="http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-400.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="249" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-400.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.pngFix.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.easing.min.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.lavalamp.min.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/my-menu.js"></script>

<!-- this product is released under General Public License. Please see the attached file for details. You can also find details about the license at http://www.opensource.org/licenses/gpl-license.php -->
<script type="text/javascript">
/* <![CDATA[ */

jQuery(document).ready(function(){ 
    jQuery(document).pngFix(); 
});

/* ]]> */ 
</script>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21904869-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<style type="text/css">

/* banner rotator styles */
div#banner_rotator  {
    width:960px; height:80px;
    padding:0px;
    background-color:#000;
}

div#banner_rotator span {
    display: block; text-align: center;
}

div#banner_rotator a:link,
div#banner_rotator a:visited, 
div#banner_rotator a:hover {
    color:#0F2F8D;
    text-decoration:none;
}

</style>

<script src="http://www.dragracecanada.com/js/dw_rotate_banner.js" type="text/javascript"></script>
<script type="text/javascript">

DYN_WEB.Event.domReady( function() {
    
    var banner = {
        id: 'banner_rotator', // id of element that displays rotating content
        speed: 6000, // default 4500
        bPause: false, // pause/resume onmouseover/out
        // banner content goes here
        // commas separate items, but no comma after last item
        content: ['<a href="http://www.mopar.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2016/12/high-performance-1.jpg" border="0"></span></a>',
            '<a href="http://www.lucasoil.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LucasOil-banner-2017.jpg" border="0"></span></a>',
	    '<a href="http://www.loudmusicloudcars.com/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LMLC-960X80-1.jpg" border="0"></span></a>'
        ]
    };
    
    new DYN_WEB.Banner_Rotator(banner);
    
});

</script>
</head>

<body>

<div id="wrapper" align="center">
	<div id="layouttop"></div>
    
    <!-- Header Starts -->
    <div id="header" align="center">
	<a href="http://www.dragracecanada.com/">
	    <img src="http://dragracecanada.com/wp-content/uploads/2014/12/DRC_Logo_trans.png" border="0">
	</a>
	<SPAN STYLE="font-family: Arial; font-size: 16px; font-decoration: bold; font-style: italic ; color: #FFFFFF"><br>proudly presented by:&nbsp;&nbsp;</SPAN>
	<br>
	<br>
	<div id="banner_rotator"><a href="http://www.lucasoil.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LucasOil-banner-2017.jpg" border="0"></span></a></div>
    	<!-- 				<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="990" height="150" id="mediaHeader" align="middle">
				<param name="allowScriptAccess" value="sameDomain" />
				<param name="allowFullScreen" value="false" />
				<param name="wmode" value="transparent" />
				<param name="movie" value="http://dragracecanada.com/wp-content/header-images/DRC2013.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" />	
				<embed src="http://dragracecanada.com/wp-content/header-images/DRC2013.swf" wmode="transparent" quality="high" bgcolor="#ffffff" width="990" height="150" name="mediaHeader" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
				</object>
		 -->        
    </div>
    <!-- Header Ends -->

    <div id="innerwrapper">

    	
        <!-- Main nav Starts here -->
<!--
        <div id="navouter">
            <div id="nav">

<ul class="lavalamp" id="menu1">  
<li class="page_item "><a href="http://dragracecanada.com">Home</a></li> 
		<li class="cat-item cat-item-10"><a href="http://dragracecanada.com/category/performance-pipeline/" >BWD Performance Pipeline</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://dragracecanada.com/category/editors-extra/" >Editor&#039;s Extra</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://dragracecanada.com/category/international-dateline/" >International Dateline</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://dragracecanada.com/category/hotzone/" >Lucas Oil Hotzone</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://dragracecanada.com/category/national-news/" >Mopar Canada &#8211; National News</a>
</li>
	<li class="cat-item cat-item-9"><a href="http://dragracecanada.com/category/northern-exposure/" >Northern Exposure</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://dragracecanada.com/category/team-blogs/" title="Team Blogs">Paton Racing Blog</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://dragracecanada.com/category/photo-gallery/" >Photo Gallery</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://dragracecanada.com/category/unassigned/" >Unassigned</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://dragracecanada.com/category/the-pro-mod-portal/" >VP Racing Pro Mod Portal</a>
</li>
		 	
</ul> 
          
            </div>
        </div>
 //-->
        <!-- Main nav Ends -->
<div id="maincol">

<br><div align="center"><a href="http://www.vpracingfuels.com/vp-drag-racing" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2015/02/VP_ReadyFortheTrack_570x70.gif" width="100%" border="0"></a></div><br>
		
        <div class="postwrap">
          	<h2 class="posttitle"><a href="http://dragracecanada.com/record-pace-pdra-round-one/">Record Pace @ PDRA Round One!</a></h2>
          	<div class="postmeta">by <a href="http://dragracecanada.com/author/editor/" title="Posts by editor" rel="author">editor</a> on Mar.13, 2017, under <a href="http://dragracecanada.com/category/the-pro-mod-portal/" rel="category tag">VP Racing Pro Mod Portal</a></div>
            <div class="clr16"></div>
          	<div class="postcontent"><p><em>Drag Racing’s marquee 1/8th mile circuit opened for season business in South Georgia last weekend…</em><span id="more-26379"></span></p>
<p>The legendary South Georgia Motorsports Park eighth-mile played host to the record-breaking doorslammers of the Professional Drag Racers Association (PDRA) this weekend, with Florida’s Tommy D’Aprile scoring the PDRA Southern Extreme Nationals event win in Pro Extreme. Also earning pro class wins Saturday night were Jay Cox in Pro Nitrous, Jose Gonzales in Pro Boost, John Montecalvo in Extreme Pro Stock, and Eric McKinney in Pro Extreme Motorcycle.</p>
<p>The sportsman class winners at the PDRA’s 2017 season opener were Tom Vanbeek in Top Sportsman, Mario Boesch in Top Dragster, Sadie Wicks in Pro Junior Dragster, and Tripp McCarty in Top Junior Dragster. Georgia racer Ken Grant scored the Bracket Bash victory.</p>
<p><strong>PRO EXTREME</strong> &#8211; Veteran Pro Extreme wheelman Tommy D’Aprile notched the first win on his 2017 scorecard when he drove the Mel Bush Motorsports 2015 Corvette to a decisive win over Jose Gonzales in the final round.</p>
<p>D’Aprile entered eliminations as the number-two qualifier with a 3.551 et. A 3.54 at 215.55 mph followed in the first round over Danny Lowry, who was unable to make the run. A timelier bye run in the second round allowed D’Aprile to move on to the semis despite slowing to a 3.811. D’Aprile dipped back into the mid-3.5s with a 3.562 at 209.01 to defeat Californian Jay Dietrich, though the screw-blown Hemi was wounded in the process. The Al Billes-led team rushed into action repairing the power plant during the short turnaround time before the final. With opponent Jose Gonzales patiently waiting, D’Aprile and team were able to return to the line to run 3.586 at 212.73 mph to defeat the 3.657-second effort by Gonzales.</p>
<p>“We had to tear the motor down and put it back together before the final,” D’Aprile said. “We didn’t even test fire it. The starter wouldn’t come off at first when we fired up for the final, then we had a bent throttle cable so we didn’t have full throttle in the final. The throttle was actually sticking so I had to hold my foot back while I was staging. It just all worked out, that’s all I can say – God is good.”</p>
<div id="attachment_26378" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/pdra-pxfinals/"><img class="size-full wp-image-26378" src="http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-PXFinals.jpg" alt="" width="500" height="258" srcset="http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-PXFinals.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-PXFinals-300x155.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-PXFinals-400x206.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">The P/X final featured a battle of C7 Corvette cars with Tommy D&#8217;Aprile supercharged car (far lane) topping the turbo car driven by Jose Gonzales</p></div>
<p>Gonzales, who drove the El General/Q80 Racing 2016 Corvette to a world-record 5.406 quarter mile et earlier in the weekend, certainly earned his way into the final. The twin-turbocharged entry improved from a 3.601 at 222.25 to a 3.575 at 219.01 in the first two rounds, then Gonzales scored a sizable holeshot win over Swedish FIA Pro Mod champion Mattias Wulcan in the semifinals.</p>
<p>Even with such a proven competitor in the other lane, D’Aprile stayed focused on the task at hand to take the win back home to Port Charlotte, Florida.</p>
<p>“With all due respect, I never care who I’m racing because I’m my own guy – I cut my tree, drive my lane and do what I need to do. I never worry about who’s in the other lane. I’ve got confidence in what we’ve got in the race car and who we have putting it together – Al Billes and all the guys on this Mel Bush Motorsports team. I really owe it all to them, as well as Mel and Johanne Bush for giving me the opportunity to run their race car,” D’Aprile added gratefully.</p>
<div id="attachment_26377" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/pdra-px-scruggs/"><img class="size-full wp-image-26377" src="http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-PX-Scruggs.jpg" alt="" width="500" height="313" srcset="http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-PX-Scruggs.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-PX-Scruggs-300x188.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-PX-Scruggs-400x250.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Jason Scruggs set both low ET and top speed with a ridiculously fast 3.499 secs at 221.52 mph during qualifying.</p></div>
<p><strong>PRO NITROUS &#8211;  </strong>Switzer Dynamics Pro Nitrous presented by MoTeC star Jay Cox, winner of three of the nine PDRA races in 2016, kicked off the new season with possibly his most successful weekend performance yet. The former Minor League Baseball player used two elusive 3.6-second passes to secure the PDRA Southern Extreme Nationals low qualifier award and event win.</p>
<p>Cox drove his fan-favorite “Pumpkin” ’69 Camaro to a 3.679 at 200.71 mph – just two thousandths away from the et record – to claim the number one spot in qualifying. The Buck-powered entry stayed in the 3.7s for round wins over Lee Adkins, Jim Laurita, and Danny Perry. With final-round opponent Lizzy Musi having recorded a pair of 3.68s at well over 200 mph in the prior two rounds, Cox knew he would need a little extra motivation. He delivered a 3.697 at 199.91 to take down Musi and her 3.719 at 204.08 after the two Pro Nitrous hotshots engaged in a lengthy staging duel.</p>
<p>“I think the world of Lizzy and [her father and tuner] Pat Musi,” Cox said. “They have a bad hot rod. I grew up playing ball and a lot of people would try to get in my head; I live for that. If someone goes in and lights the tree up, I’m kinda bored. But when you want to play games, I get fired up; I get in the zone. I don’t plan anything, I just do it by feel. Me and Lizzy were just having a little fun with that staging battle. That’s what makes drag racing great.”</p>
<div id="attachment_26375" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/pdra-cox/"><img class="size-full wp-image-26375" src="http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-Cox.jpg" alt="" width="500" height="299" srcset="http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-Cox.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-Cox-300x179.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-Cox-400x239.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">The Pro Nitrous winner was the super swift and consistent Camaro of Jay Cox</p></div>
<p>The season-opening win has special meaning for Cox, who was sent looking for a new major sponsor over the winter. He found one in Garysburg, North Carolina-based Clements Mechanical, a mechanical engineering firm new to the sport.</p>
<p>“It’s awesome to start off the year like this,” Cox added. “My new sponsor, Luke Clements at Clements Mechanical, he’s new to drag racing. He had about 20 of his people here supporting us. For him to put all of that faith in me is pretty special to me. I’m glad we could start things off on the right foot with this win.”</p>
<p><strong>PRO BOOST</strong> &#8211; While Jose Gonzales made headlines this weekend for his record-shattering quarter-mile run in the El General/Q80 Racing Pro Extreme car, his performance in Andy McCoy Race Cars Pro Boost was also impressive.</p>
<p><a href="http://dragracecanada.com/record-pace-pdra-round-one/pdra-proboostw/" rel="attachment wp-att-26376"><img class="aligncenter size-full wp-image-26376" src="http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-ProBoostW.jpg" alt="" width="499" height="322" srcset="http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-ProBoostW.jpg 499w, http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-ProBoostW-300x194.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/03/PDRA-ProBoostW-400x258.jpg 400w" sizes="(max-width: 499px) 100vw, 499px" /></a></p>
<p>Gonzales recorded a weekend-best 3.684 at 214.66 mph to qualify number one, then laid down back-to-back 3.688s to dispatch the supercharged entries of Larry Higginbotham and Ric Fleck. A 3.686 at 213.33 was enough to beat rising young star Ty Tutterow in the semifinals. He then used a starting-line advantage and 3.703-second pass to beat GALOT Motorsports driver John Strickland’s 3.723 in the final round.</p>
<p>In his winning effort, Gonzales also performed several of the fastest runs in Pro Boost history over the course of the weekend. The Pro Line-powered Mustang was consistently in the 213 mph range throughout eliminations, though a best speed of 215.2 mph was set in the opening round.</p>
<div id="attachment_26383" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/pb_john-strickland/"><img class="size-full wp-image-26383" src="http://dragracecanada.com/wp-content/uploads/2017/03/PB_John-Strickland-e1489415774187.jpg" alt="" width="500" height="281" /></a><p class="wp-caption-text">John Strickland was r/up in the very competitive Pro Boost class category.</p></div>
<p><em>EXTREME PRO STOCK</em> &#8211;  New York paving contractor John Montecalvo added another win to his illustrious mountain-motor Pro Stock career with his PDRA Southern Extreme Nationals win in Extreme Pro Stock. The number-two qualifier had his 2015 Camaro running consistently in the mid-4.0-second range, eventually defeating first-time Pro Stock finalist Scott Benham, who crossed the centerline.</p>
<p>“It feels phenomenal to get the first win of the season,” said Montecalvo after running 4.087 in the final. “We really struggled this weekend. We tested Thursday and didn’t do very well. Our original plan for Thursday was to make two runs on the car, put it in the trailer and go out to dinner. It didn’t quite work out that way. We just couldn’t get a handle on the track and had to change our setup completely, but sometimes those weekends that start out the worst way end up the best. Tommy Lee, William, Cory, and my wife, Lois Anne, all did a great job – it was a real team effort.”</p>
<p><em>PRO EXTREME MOTORCYCLE</em> &#8211; Defending Drag 965 Pro Extreme Motorcycle world champion Eric McKinney showed no signs of stopping his championship ways this weekend. The three-time PDRA champion defeated his teammate and tuner, Ashley Owens, in an all-McKinney Motorsports final round.</p>
<p>“The performance this weekend was just stellar,” McKinney said. “We started off where we left off last year. We had a couple good days of testing and thought we could just put it on cruise control for qualifying, but it wasn’t easy.”<br />
McKinney was the provisional low qualifier after Friday’s two qualifying sessions, though he was bumped to third in Saturday’s final session by Owens and Terry Schweigert. The Ohio rider’s Suzuki went progressively quicker in eliminations, beginning with a 4.07 at 176.7 mph over Monte Campbell and ending with a dominant 3.99 at 179.52 over Schweigert in the semifinals. Another sub-four-second pass nearly followed in the final, but McKinney’s 4.001 at 179.04 was quick enough to hold off low qualifier Owens and his 4.024 at 177.72.</p>
<p>“To run 3.99 in the semifinals was incredible, but that’s what it’s going to take to win races this season,” McKinney pointed out. “We were trying to run side-by-side threes in the final. This class is tough this year, and to start the year off like this is just awesome.”</p>
<p>The next stop on the 2017 PDRA Tour is the 2017 PDRA East Coast Nationals, March 30-April 1, at GALOT Motorsports Park in Benson, NC.</p>
<p><a href="http://dragracecanada.com/pdra-star/"><img class="aligncenter size-full wp-image-26046" src="http://dragracecanada.com/wp-content/uploads/2017/02/PDRA-star-e1489415056733.png" alt="" width="500" height="349" /></a><br />
<em>ABOUT THE PDRA</em> &#8211; With offices in Pittsboro, North Carolina, and Saltillo, Mississippi, the Professional Drag Racers Association is the top sanctioning body in the United States for the sport of eighth-mile drag racing. The PDRA’s professional categories include Pro Extreme Motorcycle, Extreme Pro Stock, Pro Boost, Pro Nitrous and Pro Extreme, the quickest doorslammer class in drag racing. The 2017 PDRA schedule consists of eight national events. For more information on the PDRA, visit www.PDRA660.com.</p>
<p style="text-align: center;"><em>Posted by Nate Van Wagnen </em><br />
<em>Photos by Roger Richards</em></p>
</div>
          	<div class="clr"></div>
          	<span class="linkpages"></span><div class="cleared"></div>
          	
			            
				<div class="roundcornrrbox">
                   	<div class="topleftcorner"><div class="toprightcorner"></div></div>
                    <div class="roubcornrcontent">
            			<span class="posttags-single">No tags</span>
                    	<div class="clr"></div>
                    </div>
                    <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
                </div>                        
                        
			
			        	
            <div class="clr"></div>
        </div> <!-- Closes topPost -->
		<small></small>

		<div id="comments">
			            <!-- WP 2.7 and above -->
                        
                    </div> <!-- Closes Comment -->

<div id="extrastuff">
<span id="rssleft"><a href="http://dragracecanada.com/record-pace-pdra-round-one/feed/"><abbr title="Really Simple Syndication">RSS</abbr> feed for this post (comments)</a></span>

<span id="trackright"></span>
<div class="cleared"></div>
</div>


<br><div align="center"><a href="http://napashowdowns.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/03/USDRS_570x70.gif" border="0"></a></div><br>
</div><!-- Closes Main -->


<div id="rightcol">
	<div class="roundcornrrbox">
    <div class="topleftcorner"><div class="toprightcorner"></div></div>
    <div class="roundcrrcnt">
    

        	<div id="searchboxo">
        		<form method="get" id="searchform" action="http://dragracecanada.com/">
    <input type="text" value="Search DragRaceCanada" name="s" id="searchbox" onfocus="this.value=''" class="searchinput"/>
    <input type="submit" class="submitbutton" value="Search" />
</form> 
        </div>

        <!-- widget -->
                    <div class="widget-cat">
                <h4>Categories</h4>
                <ul>
                    	<li class="cat-item cat-item-10"><a href="http://dragracecanada.com/category/performance-pipeline/" >BWD Performance Pipeline</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://dragracecanada.com/category/editors-extra/" >Editor&#039;s Extra</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://dragracecanada.com/category/international-dateline/" >International Dateline</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://dragracecanada.com/category/hotzone/" >Lucas Oil Hotzone</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://dragracecanada.com/category/national-news/" >Mopar Canada &#8211; National News</a>
</li>
	<li class="cat-item cat-item-9"><a href="http://dragracecanada.com/category/northern-exposure/" >Northern Exposure</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://dragracecanada.com/category/team-blogs/" title="Team Blogs">Paton Racing Blog</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://dragracecanada.com/category/photo-gallery/" >Photo Gallery</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://dragracecanada.com/category/unassigned/" >Unassigned</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://dragracecanada.com/category/the-pro-mod-portal/" >VP Racing Pro Mod Portal</a>
</li>
                </ul>
            </div>

<div align="center"><img src="http://dragracecanada.com/wp-content/uploads/2013/04/mopar_national_news.gif" border="0" vspace="4"><br><br></div>

         

        <br><div align="center"><script type="text/javascript"><!--
google_ad_client = "pub-9456405457314885";
google_ad_width = 120;
google_ad_height = 600;
google_ad_format = "120x600_as";
google_ad_channel ="";
google_color_border = "666666";
google_color_bg = "000000";
google_color_link = "FFFFFF";
google_color_url = "FF0000";
google_color_text = "FF0000";
//--></script>
<script type="text/javascript"
  src="http://pagead2.googlesyndication.com/pagead/show_ads.js"> 
</script></div><br>        <div align="center">        
            <a href="http://dragracecanada.com">
                <img src="http://www.dragracecanada.com/images/drc_wordpress_returnhome.gif" width="250" height="129" vspace="2" alt="DragRaceCanada.com" />
            </a>
        </div>


        <div class="clr"></div>
    </div>
    <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
</div>
</div>
<div class="clr"></div>




    <div id="dhtmlgoodies_slideshow">
	<div id="galleryContainer" align="center">
		<div id="arrow_left"><img src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/img/arrow_left.gif"></div>
		<div id="arrow_right"><img src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/img/arrow_right.gif"></div>
		<div id="theImages">
				<!-- Thumbnails -->
			<a href="http://www.mopar.com" target="_blank"><img src="http://www.dragracecanada.com/images/wordpress/mopar_chain.jpg"></a>
			<a href="http://www.lucasoil.ca" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2015/05/lucasoil_lg.gif"></a>
			<a href="http://www.vpracingfuels.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2014/05/vp_2014.gif"></a>
			<a href="http://www.castrolraceway.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2011/08/castrol_raceway.gif"></a>
			<a href="http://www.joestransmission.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/02/joestransmission.gif"></a>
			<a href="http://fasteddieracewear.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/fasteddie_logo_2016.gif"></a>
			<a href="http://www.tracklessvehicles.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2014/08/Trackless_182x70.gif"></a>
			<a href="http://www.bigwestdodge.ca" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/03/bigwestdodge_th.jpg"></a>
			<a href="http://www.enationalperformance.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/NPW.png"></a>
			<a href="http://www.karbelt.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/Karbelt.png"></a>
			<a href="http://www.partspro.ca/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/PartsPro-CA.png"></a>
			<a href="http://www.acemfg.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/05/ace_mfg_152x70.gif"></a>
			<a href="http://www.boychuk.net/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2010/09/Boychuk182x70.gif"></a>
			<a href="http://www.artcal.com" target="_blank"><img src="http://www.dragracecanada.com/graphics/artcal.gif"></a>
			<a href="http://www.joestransmission.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/03/boniferro_185x70"></a>
			<a href="http://www.mellingselectperformance.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/mel.png"></a>
			<a href="http://www.arp-bolts.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/arp_190x70.gif"></a>
			<a href="https://www.flex-a-lite.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/flexalite_112x67.gif"></a>				<a href="http://www.OconnorRV.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/oconner_142x70.gif"></a>			<!-- End thumbnails -->
				
				<div id="slideEnd"></div>
		</div>
	</div>
</div>
	<div id="bottompanel">
    <div class="roundcornrrbox">
        <div class="topleftcorner"><div class="toprightcorner"></div></div>
        <div class="roundcrrcnt">
        
        	
            <div class="col1">
                
					                    <h3>Recent Posts</h3>
                    <ul>
                                                    <li>
                                <a href="http://dragracecanada.com/2017-pro-mod-schedule/">2017 Pro Mod Schedule </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/record-pace-pdra-round-one/">Record Pace @ PDRA Round One! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/torontos-motorama-photo-highlights/">Toronto&#8217;s Motorama &#8211; Photo Highlights </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/mopar-momentum-a-big-show-element/">Mopar Momentum Swings a Big Show Element! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/march-meet-canadian-photo-extra/">March Meet &#8211; Canadian Photo Extra </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/pacemaker-tremor-time/">Pacemaker Tremor Measurement </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/hot-cars-hot-topics-11/">Hot Cars Hot Topics </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/western-showmanship-hospitality/">Entertainment from Edmonton! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/vp-racing-fuelspdra-continuum/">VP Racing Fuels/PDRA Continuum </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/scottis-second-session-scheduled/">Scotti Schedules Second Session! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/phoenix-canadian-photo-extra/">Phoenix Canadian Photo Extra </a>
                            </li>
                        			
                    </ul>
                    

                            </div>
            
            <div class="col2">
                      
                    <h3>Archives</h3>
                    <ul>
                        	<li><a href='http://dragracecanada.com/2017/03/'>March 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/02/'>February 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/01/'>January 2017</a></li>
	<li><a href='http://dragracecanada.com/2016/12/'>December 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/11/'>November 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/10/'>October 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/09/'>September 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/08/'>August 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/07/'>July 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/06/'>June 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/05/'>May 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/04/'>April 2016</a></li>
                    </ul>

                            </div>
            
            <div class="clr"></div>
        

            <div class="clr"></div>
        </div>
        <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
    </div>
</div>
<!-- Bottom Panel ends -->


	
    <div class="copyr">Copyright &copy; 1996-2016 DragRaceCanada.com. All rights reserved.</div>    
    <div class="clr16"></div>
	</div>
    <div id="layoutbottom"></div>
</div>

<div id="credit" align="center">
	<abbr title="Jarrah/1.7">Jarrah</abbr> theme by <a href="http://www.templatesnext.org/">Templates Next</a> 
    | Powered by <a href="http://wordpress.org/">WordPress</a> 
</div>

	<div style="display:none">
	</div>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201711'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Maraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201711.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.0.3',blog:'26164618',post:'26379',tz:'-7',srv:'dragracecanada.com'} ]);
	_stq.push([ 'clickTrackerInit', '26164618', '26379' ]);
</script>

</body>
</html>