<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"  />
<title>NHRA Maple Grove &#8211; Canadian Photo Extra &laquo;  DragRaceCanada.com</title>
<meta name="generator" content="WordPress 4.7.6" />
<meta name="robots" content="follow, all" />

<link rel="shortcut icon" href="http://dragracecanada.com/wp-content/themes/jarrah/favicon.ico" />
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="DragRaceCanada.com RSS Feed" href="http://dragracecanada.com/feed/" />
<link rel="pingback" href="http://dragracecanada.com/xmlrpc.php" />
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/css/menu.css" type="text/css" media="screen" />
<!--[if IE]><link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/css/ie.css" type="text/css" media="screen" /><![endif]-->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/dragracecanada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.6"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='http://dragracecanada.com/wp-content/plugins/ditty-news-ticker/assets/fontastic/styles.css?ver=2.0.15' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='http://dragracecanada.com/wp-content/plugins/ditty-news-ticker/assets/css/style.css?ver=2.0.15' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='http://dragracecanada.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://dragracecanada.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.0.3' type='text/css' media='all' />
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/flash-album-gallery/admin/js/swfobject.js?ver=2.2'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/flash-album-gallery/admin/js/swfaddress.js?ver=2.4'></script>
<link rel='https://api.w.org/' href='http://dragracecanada.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://dragracecanada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://dragracecanada.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='CMDRA Wraps Up 2017 Season' href='http://dragracecanada.com/cmdra-wraps-up-2017-season/' />
<meta name="generator" content="WordPress 4.7.6" />
<link rel="canonical" href="http://dragracecanada.com/nhra-maple-grove-canadian-photo-extra/" />
<link rel='shortlink' href='http://wp.me/p1LMBY-7wJ' />
<link rel="alternate" type="application/json+oembed" href="http://dragracecanada.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragracecanada.com%2Fnhra-maple-grove-canadian-photo-extra%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://dragracecanada.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragracecanada.com%2Fnhra-maple-grove-canadian-photo-extra%2F&#038;format=xml" />
<script type='text/javascript'>AC_FL_RunContent = 0;</script><script type='text/javascript' src="http://dragracecanada.com/wp-content/plugins/dynamic-headers/AC_RunActiveContent.js"></script><link rel="stylesheet" href="http://dragracecanada.com/wp-content/plugins/logo-slideshow/css/image-slideshow.css" type="text/css" media="screen" charset="utf-8"/>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/image-slideshow.js"></script>
	
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/plugins/wp-photo-album/theme/wppa_style.css" type="text/css" media="screen" />
		
<!-- <meta name='Grand Flagallery' content='4.41' /> -->

<link rel='dns-prefetch' href='//v0.wordpress.com'>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="NHRA Maple Grove &#8211; Canadian Photo Extra" />
<meta property="og:url" content="http://dragracecanada.com/nhra-maple-grove-canadian-photo-extra/" />
<meta property="og:description" content="Presented by RAD Torque Systems &#8212; snapshots of some great Canadian racers and cars at last weekend&#8217;s NHRA Dodge Nationals in PA&#8230;." />
<meta property="article:published_time" content="2017-09-28T15:50:43+00:00" />
<meta property="article:modified_time" content="2017-09-28T20:10:31+00:00" />
<meta property="og:site_name" content="DragRaceCanada.com" />
<meta property="og:image" content="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-400-x.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="250" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-400-x.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.pngFix.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.easing.min.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.lavalamp.min.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/my-menu.js"></script>

<!-- this product is released under General Public License. Please see the attached file for details. You can also find details about the license at http://www.opensource.org/licenses/gpl-license.php -->
<script type="text/javascript">
/* <![CDATA[ */

jQuery(document).ready(function(){ 
    jQuery(document).pngFix(); 
});

/* ]]> */ 
</script>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21904869-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<style type="text/css">

/* banner rotator styles */
div#banner_rotator  {
    width:960px; height:80px;
    padding:0px;
    background-color:#000;
}

div#banner_rotator span {
    display: block; text-align: center;
}

div#banner_rotator a:link,
div#banner_rotator a:visited, 
div#banner_rotator a:hover {
    color:#0F2F8D;
    text-decoration:none;
}

</style>

<script src="http://www.dragracecanada.com/js/dw_rotate_banner.js" type="text/javascript"></script>
<script type="text/javascript">

DYN_WEB.Event.domReady( function() {
    
    var banner = {
        id: 'banner_rotator', // id of element that displays rotating content
        speed: 6000, // default 4500
        bPause: false, // pause/resume onmouseover/out
        // banner content goes here
        // commas separate items, but no comma after last item
        content: ['<a href="http://www.mopar.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2016/12/high-performance-1.jpg" border="0"></span></a>',
            '<a href="http://www.lucasoil.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LucasOil-banner-2017.jpg" border="0"></span></a>',
	    '<a href="http://www.loudmusicloudcars.com/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LMLC-960X80-1.jpg" border="0"></span></a>'
        ]
    };
    
    new DYN_WEB.Banner_Rotator(banner);
    
});

</script>
</head>

<body>

<div id="wrapper" align="center">
	<div id="layouttop"></div>
    
    <!-- Header Starts -->
    <div id="header" align="center">
	<a href="http://www.dragracecanada.com/">
	    <img src="http://dragracecanada.com/wp-content/uploads/2014/12/DRC_Logo_trans.png" border="0">
	</a>
	<SPAN STYLE="font-family: Arial; font-size: 16px; font-decoration: bold; font-style: italic ; color: #FFFFFF"><br>proudly presented by:&nbsp;&nbsp;</SPAN>
	<br>
	<br>
	<div id="banner_rotator"><a href="http://www.lucasoil.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LucasOil-banner-2017.jpg" border="0"></span></a></div>
    	<!-- 				<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="990" height="150" id="mediaHeader" align="middle">
				<param name="allowScriptAccess" value="sameDomain" />
				<param name="allowFullScreen" value="false" />
				<param name="wmode" value="transparent" />
				<param name="movie" value="http://dragracecanada.com/wp-content/header-images/DRC2013.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" />	
				<embed src="http://dragracecanada.com/wp-content/header-images/DRC2013.swf" wmode="transparent" quality="high" bgcolor="#ffffff" width="990" height="150" name="mediaHeader" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
				</object>
		 -->        
    </div>
    <!-- Header Ends -->

    <div id="innerwrapper">

    	
        <!-- Main nav Starts here -->
<!--
        <div id="navouter">
            <div id="nav">

<ul class="lavalamp" id="menu1">  
<li class="page_item "><a href="http://dragracecanada.com">Home</a></li> 
		<li class="cat-item cat-item-9"><a href="http://dragracecanada.com/category/northern-exposure/" >ACE MFG/O&#039;Connor RV Northern Exposure</a>
</li>
	<li class="cat-item cat-item-10"><a href="http://dragracecanada.com/category/performance-pipeline/" >BWD Performance Pipeline</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://dragracecanada.com/category/hotcars-hottopics/" >Hot Cars/Hot Topics</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://dragracecanada.com/category/international-dateline/" >International Dateline</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://dragracecanada.com/category/hotzone/" >Lucas Oil Hotzone</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://dragracecanada.com/category/national-news/" >Mopar Canada &#8211; National News</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://dragracecanada.com/category/team-blogs/" title="Team Blogs">Paton Racing Blog</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://dragracecanada.com/category/photo-gallery/" >Photo Gallery</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://dragracecanada.com/category/editors-extra/" >RAD Editor&#039;s Extra</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://dragracecanada.com/category/the-pro-mod-portal/" >VP Racing Pro Mod Portal</a>
</li>
		 	
</ul> 
          
            </div>
        </div>
 //-->
        <!-- Main nav Ends -->
<div id="maincol">

<br><div align="center"><a href="http://radtorque.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/07/RAD-570x70-v2.gif" border="0"></a></div><br>
		
        <div class="postwrap">
          	<h2 class="posttitle"><a href="http://dragracecanada.com/nhra-maple-grove-canadian-photo-extra/">NHRA Maple Grove &#8211; Canadian Photo Extra</a></h2>
          	<div class="postmeta">by <a href="http://dragracecanada.com/author/editor/" title="Posts by editor" rel="author">editor</a> on Sep.28, 2017, under <a href="http://dragracecanada.com/category/editors-extra/" rel="category tag">RAD Editor's Extra</a></div>
            <div class="clr16"></div>
          	<div class="postcontent"><p><em>Presented by RAD Torque Systems &#8212; snapshots of some great Canadian racers and cars at last weekend&#8217;s NHRA Dodge Nationals in PA&#8230;.</em><span id="more-28937"></span></p>
<p><a href="http://radtorque.com" rel="attachment wp-att-28520"><img class="aligncenter size-full wp-image-28520" src="http://dragracecanada.com/wp-content/uploads/2017/09/RAD-470-x-125-v2.gif" alt="" width="470" height="125" /></a></p>
<p><a href="http://dragracecanada.com/drc-mg-allyn/"><img class="aligncenter size-full wp-image-28921" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Allyn.jpg" alt="" width="500" height="357" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Allyn.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Allyn-300x214.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Allyn-385x275.jpg 385w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
<div id="attachment_28926" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/drc-mg-johna/"><img class="size-full wp-image-28926" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-JohnA.jpg" alt="" width="500" height="376" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-JohnA.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-JohnA-300x226.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-JohnA-366x275.jpg 366w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Super creative Nova Scotia-based brothers <strong>John and Allyn Armstrong</strong> were again entered at Maple Grove Raceway. Allyn qualified his L/A Opel GT in Comp and John ran his &#8217;69 Corvette in GT/AA trim in Super Stock at the event.</p></div>
<div id="attachment_28935" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/drc-mg-tyler/"><img class="size-full wp-image-28935" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Tyler.jpg" alt="" width="500" height="398" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Tyler.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Tyler-300x239.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Tyler-345x275.jpg 345w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text"><strong>Tyler Scott</strong> and the rest of the Harmon HVS/Kardiac Kids team had yet another strong performance in NHRA. The team qualified #6 but lost a heartbreaking holeshot decision to Dan Pomponio in round #1 &#8211; 5.633 secs to 5.631 secs.</p></div>
<div id="attachment_28930" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/drc-mg-oakes/"><img class="size-full wp-image-28930" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Oakes.jpg" alt="" width="500" height="406" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Oakes.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Oakes-300x244.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Oakes-339x275.jpg 339w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Maritimes-based racer <strong>Brian Oakes</strong> did this lengthly (but crowd pleasing) wheel stand in round #2 which unfortunately took him out of Super Stock competition</p></div>
<div id="attachment_28929" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/drc-mg-mercier/"><img class="size-full wp-image-28929" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Mercier.jpg" alt="" width="500" height="338" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Mercier.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Mercier-300x203.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Mercier-400x270.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text"><strong>Al Moeser</strong> had another driving stint in the powerful injected nitro car owned by Quebec&#8217;s <strong>Daniel Mercier</strong>. Al qualified #19 &#8211; but lost out to Dan Page in round one.</p></div>
<div id="attachment_28934" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/drc-mg-thibeault2/"><img class="size-full wp-image-28934" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Thibeault2.jpg" alt="" width="500" height="336" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Thibeault2.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Thibeault2-300x202.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Thibeault2-400x269.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Veteran racer <strong>Fred Thibeault</strong> (Middleton NS) qualified his B/SA Camaro #8 (-.916) &#8211; but lost out in round two of Stock eliminator.</p></div>
<div id="attachment_28923" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/drc-mg-grenier/"><img class="size-full wp-image-28923" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Grenier.jpg" alt="" width="500" height="328" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Grenier.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Grenier-300x197.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Grenier-400x262.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Quebec&#8217;s <strong>Richard Grenier</strong> once again ran his very unique &#8217;33 Willys at the MGR event. Grenier&#8217;s machine (which is Mopar-powered) broke out in round #2 of Super Gas.</p></div>
<p><a href="http://dragracecanada.com/drc-mg-kennysg/"><img class="aligncenter size-full wp-image-28928" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-KennySG.jpg" alt="" width="499" height="325" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-KennySG.jpg 499w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-KennySG-300x195.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-KennySG-400x261.jpg 400w" sizes="(max-width: 499px) 100vw, 499px" /></a></p>
<div id="attachment_28927" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/drc-mg-kennysc/"><img class="size-full wp-image-28927" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-KennySC.jpg" alt="" width="500" height="332" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-KennySC.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-KennySC-300x199.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-KennySC-400x266.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">As he most often does &#8211; Kingston&#8217;s <strong>Jason Kenny</strong> ran two classes in national event competition. His S/G Corvette lost in round two but he did go to the 4th round in Super Comp.</p></div>
<div id="attachment_28922" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/drc-mg-cavalier/"><img class="size-full wp-image-28922" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Cavalier.jpg" alt="" width="500" height="348" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Cavalier.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Cavalier-300x209.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Cavalier-395x275.jpg 395w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">We like this well prepped 1987 Cavalier raced in Super Gas by <strong>Jeffery Keyuk</strong> from Ashton Ontario</p></div>
<div id="attachment_28924" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/drc-mg-irvin/"><img class="size-full wp-image-28924" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Irvin.jpg" alt="" width="500" height="356" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Irvin.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Irvin-300x214.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Irvin-386x275.jpg 386w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text"><strong>Trevor Irvin</strong> (from Nerepis NS) tried his hand again in Stock with his &#8217;70 Nova. Irvin who had recently won at the NHRA divisional level &#8211; had a red-light foul in round #2.</p></div>
<div id="attachment_28931" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/drc-mg-sgmaybe/"><img class="size-full wp-image-28931" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-SGmaybe.jpg" alt="" width="500" height="439" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-SGmaybe.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-SGmaybe-300x263.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-SGmaybe-313x275.jpg 313w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">New Brunswick&#8217;s <strong>Dwight Cummings</strong> raced his great looking &#8217;57 Corvette in Super Gas.</p></div>
<div id="attachment_28932" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/drc-mg-sunfiress/"><img class="size-full wp-image-28932" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-SunfireSS.jpg" alt="" width="500" height="372" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-SunfireSS.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-SunfireSS-300x223.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-SunfireSS-370x275.jpg 370w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Quebec&#8217;s <strong>Alain Cauchon</strong> towed down from Drummondville and had a 2nd round finish driving his GT/LA &#8217;05 Sunfire in Super Stock racing.</p></div>
<div id="attachment_28936" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/drc-mg-veale/"><img class="size-full wp-image-28936" src="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Veale.jpg" alt="" width="500" height="321" srcset="http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Veale.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Veale-300x193.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/09/DRC-MG-Veale-400x257.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text"><em>Winner Winner &#8211; Chicken Dinner!</em> Stoney Creek&#8217;s <strong>Jeff Veale</strong> was for sure the top Canadian racer news maker at the Dodge Nationals &#8211; bursting though for his first ever NHRA national event win!</p></div>
<p style="text-align: center;"><em>Photos by Bruce Biegler &#8211; Steve Embling &#8211; Dave DeAngelis</em></p>
<p style="text-align: center;">To view many more event photos from the NHRA Dodge Nationals event visit our co-production photo gallery:  <a href="http://loudmusicloudcars.com/2017/09/nhra-maple-grove-2017/"><strong>HERE</strong></a></p>
</div>
          	<div class="clr"></div>
          	<span class="linkpages"></span><div class="cleared"></div>
          	
			            
				<div class="roundcornrrbox">
                   	<div class="topleftcorner"><div class="toprightcorner"></div></div>
                    <div class="roubcornrcontent">
            			<span class="posttags-single"><a href="http://dragracecanada.com/tag/allyn-armstrong/" rel="tag">Allyn Armstrong</a>, <a href="http://dragracecanada.com/tag/daniel-mercier/" rel="tag">Daniel Mercier</a>, <a href="http://dragracecanada.com/tag/jason-kenny/" rel="tag">Jason Kenny</a>, <a href="http://dragracecanada.com/tag/jeff-veale/" rel="tag">Jeff Veale</a>, <a href="http://dragracecanada.com/tag/john-armstrong/" rel="tag">John Armstrong</a>, <a href="http://dragracecanada.com/tag/trevor-irvin/" rel="tag">Trevor Irvin</a>, <a href="http://dragracecanada.com/tag/tyler-scott/" rel="tag">Tyler Scott</a></span>
                    	<div class="clr"></div>
                    </div>
                    <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
                </div>                        
                        
			
			        	
            <div class="clr"></div>
        </div> <!-- Closes topPost -->
		<small></small>

		<div id="comments">
			            <!-- WP 2.7 and above -->
                        
                    </div> <!-- Closes Comment -->

<div id="extrastuff">
<span id="rssleft"><a href="http://dragracecanada.com/nhra-maple-grove-canadian-photo-extra/feed/"><abbr title="Really Simple Syndication">RSS</abbr> feed for this post (comments)</a></span>

<span id="trackright"></span>
<div class="cleared"></div>
</div>


<br><div align="center"><a href="http://www.fasteddieracewear.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/fasteddie_2016.gif" border="0"></a></div><br>
</div><!-- Closes Main -->


<div id="rightcol">
	<div class="roundcornrrbox">
    <div class="topleftcorner"><div class="toprightcorner"></div></div>
    <div class="roundcrrcnt">
    

        	<div id="searchboxo">
        		<form method="get" id="searchform" action="http://dragracecanada.com/">
    <input type="text" value="Search DragRaceCanada" name="s" id="searchbox" onfocus="this.value=''" class="searchinput"/>
    <input type="submit" class="submitbutton" value="Search" />
</form> 
        </div>

        <!-- widget -->
                    <div class="widget-cat">
                <h4>Categories</h4>
                <ul>
                    	<li class="cat-item cat-item-9"><a href="http://dragracecanada.com/category/northern-exposure/" >ACE MFG/O&#039;Connor RV Northern Exposure</a>
</li>
	<li class="cat-item cat-item-10"><a href="http://dragracecanada.com/category/performance-pipeline/" >BWD Performance Pipeline</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://dragracecanada.com/category/hotcars-hottopics/" >Hot Cars/Hot Topics</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://dragracecanada.com/category/international-dateline/" >International Dateline</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://dragracecanada.com/category/hotzone/" >Lucas Oil Hotzone</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://dragracecanada.com/category/national-news/" >Mopar Canada &#8211; National News</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://dragracecanada.com/category/team-blogs/" title="Team Blogs">Paton Racing Blog</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://dragracecanada.com/category/photo-gallery/" >Photo Gallery</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://dragracecanada.com/category/editors-extra/" >RAD Editor&#039;s Extra</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://dragracecanada.com/category/the-pro-mod-portal/" >VP Racing Pro Mod Portal</a>
</li>
                </ul>
            </div>

<div align="center"><img src="http://dragracecanada.com/wp-content/uploads/2013/04/mopar_national_news.gif" border="0" vspace="4"><br><br></div>

         

        <br><div align="center"><script type="text/javascript"><!--
google_ad_client = "pub-9456405457314885";
google_ad_width = 120;
google_ad_height = 600;
google_ad_format = "120x600_as";
google_ad_channel ="";
google_color_border = "666666";
google_color_bg = "000000";
google_color_link = "FFFFFF";
google_color_url = "FF0000";
google_color_text = "FF0000";
//--></script>
<script type="text/javascript"
  src="http://pagead2.googlesyndication.com/pagead/show_ads.js"> 
</script></div><br>        <div align="center">        
            <a href="http://dragracecanada.com">
                <img src="http://www.dragracecanada.com/images/drc_wordpress_returnhome.gif" width="250" height="129" vspace="2" alt="DragRaceCanada.com" />
            </a>
        </div>


        <div class="clr"></div>
    </div>
    <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
</div>
</div>
<div class="clr"></div>




    <div id="dhtmlgoodies_slideshow">
	<div id="galleryContainer" align="center">
		<div id="arrow_left"><img src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/img/arrow_left.gif"></div>
		<div id="arrow_right"><img src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/img/arrow_right.gif"></div>
		<div id="theImages">
				<!-- Thumbnails -->
			<a href="http://www.mopar.com" target="_blank"><img src="http://www.dragracecanada.com/images/wordpress/mopar_chain.jpg"></a>
			<a href="http://www.lucasoil.ca" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2015/05/lucasoil_lg.gif"></a>
			<a href="http://www.vpracingfuels.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2014/05/vp_2014.gif"></a>
			<a href="http://www.castrolraceway.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2011/08/castrol_raceway.gif"></a>
			<a href="http://www.joestransmission.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/02/joestransmission.gif"></a>
			<a href="http://fasteddieracewear.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/fasteddie_logo_2016.gif"></a>
			<a href="http://www.charlesjones.ca/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/08/charles_jones_200x70.gif"></a>
			<a href="http://www.bigwestdodge.ca" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/03/bigwestdodge_th.jpg"></a>
			<a href="http://www.enationalperformance.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/NPW.png"></a>
			<a href="http://www.karbelt.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/Karbelt.png"></a>
			<a href="http://www.partspro.ca/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/PartsPro-CA.png"></a>
			<a href="http://www.acemfg.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/05/ace_mfg_152x70.gif"></a>
			<a href="http://www.boychuk.net/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2010/09/Boychuk182x70.gif"></a>
			<a href="http://www.artcal.com" target="_blank"><img src="http://www.dragracecanada.com/graphics/artcal.gif"></a>
			<a href="http://www.joestransmission.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/03/boniferro_185x70"></a>
			<a href="http://www.mellingselectperformance.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/mel.png"></a>
			<a href="http://www.arp-bolts.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/arp_190x70.gif"></a>
			<a href="https://www.flex-a-lite.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/flexalite_112x67.gif"></a>
			<a href="http://www.OconnorRV.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/oconner_142x70.gif"></a>
			<a href="http://www.energysuspension.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/03/ene.png"></a>
			<a href="http://radtorque.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/07/RAD-200x70.gif"></a>			<!-- End thumbnails -->
				
				<div id="slideEnd"></div>
		</div>
	</div>
</div>
	<div id="bottompanel">
    <div class="roundcornrrbox">
        <div class="topleftcorner"><div class="toprightcorner"></div></div>
        <div class="roundcrrcnt">
        
        	
            <div class="col1">
                
					                    <h3>Recent Posts</h3>
                    <ul>
                                                    <li>
                                <a href="http://dragracecanada.com/nhra-maple-grove-canadian-photo-extra/">NHRA Maple Grove &#8211; Canadian Photo Extra </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/cmdra-wraps-up-2017-season/">CMDRA Wraps Up 2017 Season </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/2017-nhra-schedule/">2017 NHRA Schedule </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/marvellous-maple-grove/">Marvellous @ Maple Grove ! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/validation-for-veales/">Validation for Veales! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/canadian-photo-highlights-shakedown-edition/">Canadian Photo Extra &#8211; &#8220;Shakedown Edition&#8221; </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/bringing-out-the-bast/">Bringing Out the Bast! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/opening-round-nhra-playoffs-report/">Opening Round &#8211; NHRA Playoffs Report </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/a-tad-natural-hat-trick/">A TAD Natural Hat Trick! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/rocky-mountain-winners/">(Finally) Rocky Mountain Winners! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/hot-cars-hot-topics-17/">Hot Cars &#8211; Hot Topics </a>
                            </li>
                        			
                    </ul>
                    

                            </div>
            
            <div class="col2">
                      
                    <h3>Archives</h3>
                    <ul>
                        	<li><a href='http://dragracecanada.com/2017/09/'>September 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/08/'>August 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/07/'>July 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/06/'>June 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/05/'>May 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/04/'>April 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/03/'>March 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/02/'>February 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/01/'>January 2017</a></li>
	<li><a href='http://dragracecanada.com/2016/12/'>December 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/11/'>November 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/10/'>October 2016</a></li>
                    </ul>

                            </div>
            
            <div class="clr"></div>
        

            <div class="clr"></div>
        </div>
        <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
    </div>
</div>
<!-- Bottom Panel ends -->


	
    <div class="copyr">Copyright &copy; 1996-2017 DragRaceCanada.com. All rights reserved.</div>    
    <div class="clr16"></div>
	</div>
    <div id="layoutbottom"></div>
</div>

<div id="credit" align="center">
	<abbr title="Jarrah/1.7">Jarrah</abbr> theme by <a href="http://www.templatesnext.org/">Templates Next</a> 
    | Powered by <a href="http://wordpress.org/">WordPress</a> 
</div>
	<div style="display:none">
	</div>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201739'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Sepaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.6'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/wp-embed.min.js?ver=4.7.6'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201739.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.0.3',blog:'26164618',post:'28937',tz:'-7',srv:'dragracecanada.com'} ]);
	_stq.push([ 'clickTrackerInit', '26164618', '28937' ]);
</script>

</body>
</html>