<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"  />
<title>The More Muscle the Better &laquo;  DragRaceCanada.com</title>
<meta name="generator" content="WordPress 4.7.5" />
<meta name="robots" content="follow, all" />

<link rel="shortcut icon" href="http://dragracecanada.com/wp-content/themes/jarrah/favicon.ico" />
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="DragRaceCanada.com RSS Feed" href="http://dragracecanada.com/feed/" />
<link rel="pingback" href="http://dragracecanada.com/xmlrpc.php" />
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/css/menu.css" type="text/css" media="screen" />
<!--[if IE]><link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/css/ie.css" type="text/css" media="screen" /><![endif]-->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/dragracecanada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='http://dragracecanada.com/wp-content/plugins/ditty-news-ticker/assets/fontastic/styles.css?ver=2.0.15' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='http://dragracecanada.com/wp-content/plugins/ditty-news-ticker/assets/css/style.css?ver=2.0.15' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='http://dragracecanada.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://dragracecanada.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.0.3' type='text/css' media='all' />
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/flash-album-gallery/admin/js/swfobject.js?ver=2.2'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/flash-album-gallery/admin/js/swfaddress.js?ver=2.4'></script>
<link rel='https://api.w.org/' href='http://dragracecanada.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://dragracecanada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://dragracecanada.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='A Down &#8220;Under Ultimatum&#8221;' href='http://dragracecanada.com/a-down-under-ultimatum/' />
<meta name="generator" content="WordPress 4.7.5" />
<link rel="canonical" href="http://dragracecanada.com/the-more-muscle-the-better/" />
<link rel='shortlink' href='http://wp.me/p1LMBY-7oT' />
<link rel="alternate" type="application/json+oembed" href="http://dragracecanada.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragracecanada.com%2Fthe-more-muscle-the-better%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://dragracecanada.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragracecanada.com%2Fthe-more-muscle-the-better%2F&#038;format=xml" />
<script type='text/javascript'>AC_FL_RunContent = 0;</script><script type='text/javascript' src="http://dragracecanada.com/wp-content/plugins/dynamic-headers/AC_RunActiveContent.js"></script><link rel="stylesheet" href="http://dragracecanada.com/wp-content/plugins/logo-slideshow/css/image-slideshow.css" type="text/css" media="screen" charset="utf-8"/>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/image-slideshow.js"></script>
	
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/plugins/wp-photo-album/theme/wppa_style.css" type="text/css" media="screen" />
		
<!-- <meta name='Grand Flagallery' content='4.41' /> -->

<link rel='dns-prefetch' href='//v0.wordpress.com'>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="The More Muscle the Better" />
<meta property="og:url" content="http://dragracecanada.com/the-more-muscle-the-better/" />
<meta property="og:description" content="We said it before — but it’s worth repeating — the NMCA brand of drag racing may very well be the best value out there…" />
<meta property="article:published_time" content="2017-08-30T15:46:32+00:00" />
<meta property="article:modified_time" content="2017-08-30T15:58:52+00:00" />
<meta property="og:site_name" content="DragRaceCanada.com" />
<meta property="og:image" content="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-400.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="250" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-400.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.pngFix.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.easing.min.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.lavalamp.min.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/my-menu.js"></script>

<!-- this product is released under General Public License. Please see the attached file for details. You can also find details about the license at http://www.opensource.org/licenses/gpl-license.php -->
<script type="text/javascript">
/* <![CDATA[ */

jQuery(document).ready(function(){ 
    jQuery(document).pngFix(); 
});

/* ]]> */ 
</script>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21904869-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<style type="text/css">

/* banner rotator styles */
div#banner_rotator  {
    width:960px; height:80px;
    padding:0px;
    background-color:#000;
}

div#banner_rotator span {
    display: block; text-align: center;
}

div#banner_rotator a:link,
div#banner_rotator a:visited, 
div#banner_rotator a:hover {
    color:#0F2F8D;
    text-decoration:none;
}

</style>

<script src="http://www.dragracecanada.com/js/dw_rotate_banner.js" type="text/javascript"></script>
<script type="text/javascript">

DYN_WEB.Event.domReady( function() {
    
    var banner = {
        id: 'banner_rotator', // id of element that displays rotating content
        speed: 6000, // default 4500
        bPause: false, // pause/resume onmouseover/out
        // banner content goes here
        // commas separate items, but no comma after last item
        content: ['<a href="http://www.mopar.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2016/12/high-performance-1.jpg" border="0"></span></a>',
            '<a href="http://www.lucasoil.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LucasOil-banner-2017.jpg" border="0"></span></a>',
	    '<a href="http://www.loudmusicloudcars.com/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LMLC-960X80-1.jpg" border="0"></span></a>'
        ]
    };
    
    new DYN_WEB.Banner_Rotator(banner);
    
});

</script>
</head>

<body>

<div id="wrapper" align="center">
	<div id="layouttop"></div>
    
    <!-- Header Starts -->
    <div id="header" align="center">
	<a href="http://www.dragracecanada.com/">
	    <img src="http://dragracecanada.com/wp-content/uploads/2014/12/DRC_Logo_trans.png" border="0">
	</a>
	<SPAN STYLE="font-family: Arial; font-size: 16px; font-decoration: bold; font-style: italic ; color: #FFFFFF"><br>proudly presented by:&nbsp;&nbsp;</SPAN>
	<br>
	<br>
	<div id="banner_rotator"><a href="http://www.lucasoil.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LucasOil-banner-2017.jpg" border="0"></span></a></div>
    	<!-- 				<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="990" height="150" id="mediaHeader" align="middle">
				<param name="allowScriptAccess" value="sameDomain" />
				<param name="allowFullScreen" value="false" />
				<param name="wmode" value="transparent" />
				<param name="movie" value="http://dragracecanada.com/wp-content/header-images/DRC2013.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" />	
				<embed src="http://dragracecanada.com/wp-content/header-images/DRC2013.swf" wmode="transparent" quality="high" bgcolor="#ffffff" width="990" height="150" name="mediaHeader" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
				</object>
		 -->        
    </div>
    <!-- Header Ends -->

    <div id="innerwrapper">

    	
        <!-- Main nav Starts here -->
<!--
        <div id="navouter">
            <div id="nav">

<ul class="lavalamp" id="menu1">  
<li class="page_item "><a href="http://dragracecanada.com">Home</a></li> 
		<li class="cat-item cat-item-9"><a href="http://dragracecanada.com/category/northern-exposure/" >ACE MFG/O&#039;Connor RV Northern Exposure</a>
</li>
	<li class="cat-item cat-item-10"><a href="http://dragracecanada.com/category/performance-pipeline/" >BWD Performance Pipeline</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://dragracecanada.com/category/hotcars-hottopics/" >Hot Cars/Hot Topics</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://dragracecanada.com/category/international-dateline/" >International Dateline</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://dragracecanada.com/category/hotzone/" >Lucas Oil Hotzone</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://dragracecanada.com/category/national-news/" >Mopar Canada &#8211; National News</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://dragracecanada.com/category/team-blogs/" title="Team Blogs">Paton Racing Blog</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://dragracecanada.com/category/photo-gallery/" >Photo Gallery</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://dragracecanada.com/category/editors-extra/" >RAD Editor&#039;s Extra</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://dragracecanada.com/category/the-pro-mod-portal/" >VP Racing Pro Mod Portal</a>
</li>
		 	
</ul> 
          
            </div>
        </div>
 //-->
        <!-- Main nav Ends -->
<div id="maincol">

<br><div align="center"><a href="http://radtorque.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/07/RAD-570x70-v2.gif" border="0"></a></div><br>
		
        <div class="postwrap">
          	<h2 class="posttitle"><a href="http://dragracecanada.com/the-more-muscle-the-better/">The More Muscle the Better</a></h2>
          	<div class="postmeta">by <a href="http://dragracecanada.com/author/editor/" title="Posts by editor" rel="author">editor</a> on Aug.30, 2017, under <a href="http://dragracecanada.com/category/editors-extra/" rel="category tag">RAD Editor's Extra</a></div>
            <div class="clr16"></div>
          	<div class="postcontent"><p><em>We said it before — but it’s worth repeating — the NMCA brand of drag racing may very well be the best value out there…</em><span id="more-28451"></span></p>
<p>DragRaceCanada was once again privileged to attend a major NMCA sanctioned event last weekend. The industry leading drag racing sub-culture circuit was in action at the fabulous “house that Bill built” — Summit Motorsports Park &#8212; in Norwalk Ohio. That premium facility hosted the 5th of 6 events for NMCA&#8217;s 2017 calendar year &#8211; the 16th Annual Honeywell Garrett NMCA All-American Nationals.</p>
<p><a href="http://dragracecanada.com/nmca-norwalk-9/"><img class="aligncenter size-full wp-image-28445" src="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-9.jpg" alt="" width="500" height="407" srcset="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-9.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-9-300x244.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-9-338x275.jpg 338w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
<p>This entertaining stop which showcased a wide variety and some of the creme-du-la-creme for North American’s “fast door cars” was pretty darn sensational both from a performance and participant perspective.</p>
<p>Drag racing was presented in 20+ categories with the NMCA’s marquee classes, VP Racing Fuels Xtreme Pro Mod and small tired Mickey Thompson Radial Wars, VP Racing Fuels Street Outlaw and Edelbrock Xtreme Street headlining. The event did include the latest round for the Chevrolet Performance Challenge Series which features the quickest and fastest LS and LT-based cars in North America and also included two different eliminators exclusive to Cobra Jet Mustangs, including the ’17 edition Ford Performance CJ Showdown, presented by Diversified Products Marketing.</p>
<p><a href="http://dragracecanada.com/nmca-norwalk-10/"><img class="aligncenter size-full wp-image-28446" src="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-10.jpg" alt="" width="500" height="280" srcset="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-10.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-10-300x168.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-10-400x224.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a> <a href="http://dragracecanada.com/nmca-norwalk-8/"><img class="aligncenter size-full wp-image-28444" src="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-8.jpg" alt="" width="499" height="314" srcset="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-8.jpg 499w, http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-8-300x189.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-8-400x252.jpg 400w" sizes="(max-width: 499px) 100vw, 499px" /></a></p>
<p>An added fan attraction over of the weekend was some celebrity appearances by TV’s Street Outlaw’s Stars &#8211; BoostedGT and his turbocharged ’03 SVT Mustang, Kayla Morton and her ’05 Mustang, and Derek with his ’86 Silver Unit Camaro.</p>
<p><a href="http://dragracecanada.com/nmca-norwalk-1/"><img class="aligncenter size-full wp-image-28437" src="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-1.jpg" alt="" width="500" height="325" srcset="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-1.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-1-300x195.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-1-400x260.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
<p><a href="http://dragracecanada.com/nmca-norwalk-4/"><img class="aligncenter size-full wp-image-28440" src="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-4.jpg" alt="" width="500" height="299" srcset="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-4.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-4-300x179.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-4-400x239.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
<p>Cut to the chase &#8212; this event can be best described though imagery &#8211; so check out our very extensive photo galley posted to our co-production LoudMusicLoudCars media site : <a href="http://loudmusicloudcars.com/2017/08/nmca-norwalk-2017/">HERE</a></p>
<p>To view the event&#8217;s final round result summary &#8211; visit the official NMCA site: <a href="http://www.nmcadigital.com/2017/08/27/eliminations-16th-annual-honeywell-garrett-nmca-all-american-nationals/">HERE</a></p>
<p style="text-align: center;"><em>Posted by Bruce Biegler</em><br />
<em>Photos by Bruce Biegler &amp; Steve Embling</em></p>
<p style="text-align: center;"><a href="http://dragracecanada.com/nmca-norwalk-7/"><img class="aligncenter size-full wp-image-28443" src="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-7.jpg" alt="" width="500" height="271" srcset="http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-7.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-7-300x163.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/08/NMCA-Norwalk-7-400x217.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
</div>
          	<div class="clr"></div>
          	<span class="linkpages"></span><div class="cleared"></div>
          	
			            
				<div class="roundcornrrbox">
                   	<div class="topleftcorner"><div class="toprightcorner"></div></div>
                    <div class="roubcornrcontent">
            			<span class="posttags-single"><a href="http://dragracecanada.com/tag/nmca/" rel="tag">NMCA</a>, <a href="http://dragracecanada.com/tag/summit-motorsports-park/" rel="tag">Summit Motorsports Park</a></span>
                    	<div class="clr"></div>
                    </div>
                    <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
                </div>                        
                        
			
			        	
            <div class="clr"></div>
        </div> <!-- Closes topPost -->
		<small></small>

		<div id="comments">
			            <!-- WP 2.7 and above -->
                        
                    </div> <!-- Closes Comment -->

<div id="extrastuff">
<span id="rssleft"><a href="http://dragracecanada.com/the-more-muscle-the-better/feed/"><abbr title="Really Simple Syndication">RSS</abbr> feed for this post (comments)</a></span>

<span id="trackright"></span>
<div class="cleared"></div>
</div>


<br><div align="center"><a href="http://www.fasteddieracewear.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/fasteddie_2016.gif" border="0"></a></div><br>
</div><!-- Closes Main -->


<div id="rightcol">
	<div class="roundcornrrbox">
    <div class="topleftcorner"><div class="toprightcorner"></div></div>
    <div class="roundcrrcnt">
    

        	<div id="searchboxo">
        		<form method="get" id="searchform" action="http://dragracecanada.com/">
    <input type="text" value="Search DragRaceCanada" name="s" id="searchbox" onfocus="this.value=''" class="searchinput"/>
    <input type="submit" class="submitbutton" value="Search" />
</form> 
        </div>

        <!-- widget -->
                    <div class="widget-cat">
                <h4>Categories</h4>
                <ul>
                    	<li class="cat-item cat-item-9"><a href="http://dragracecanada.com/category/northern-exposure/" >ACE MFG/O&#039;Connor RV Northern Exposure</a>
</li>
	<li class="cat-item cat-item-10"><a href="http://dragracecanada.com/category/performance-pipeline/" >BWD Performance Pipeline</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://dragracecanada.com/category/hotcars-hottopics/" >Hot Cars/Hot Topics</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://dragracecanada.com/category/international-dateline/" >International Dateline</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://dragracecanada.com/category/hotzone/" >Lucas Oil Hotzone</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://dragracecanada.com/category/national-news/" >Mopar Canada &#8211; National News</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://dragracecanada.com/category/team-blogs/" title="Team Blogs">Paton Racing Blog</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://dragracecanada.com/category/photo-gallery/" >Photo Gallery</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://dragracecanada.com/category/editors-extra/" >RAD Editor&#039;s Extra</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://dragracecanada.com/category/the-pro-mod-portal/" >VP Racing Pro Mod Portal</a>
</li>
                </ul>
            </div>

<div align="center"><img src="http://dragracecanada.com/wp-content/uploads/2013/04/mopar_national_news.gif" border="0" vspace="4"><br><br></div>

         

        <br><div align="center"><script type="text/javascript"><!--
google_ad_client = "pub-9456405457314885";
google_ad_width = 120;
google_ad_height = 600;
google_ad_format = "120x600_as";
google_ad_channel ="";
google_color_border = "666666";
google_color_bg = "000000";
google_color_link = "FFFFFF";
google_color_url = "FF0000";
google_color_text = "FF0000";
//--></script>
<script type="text/javascript"
  src="http://pagead2.googlesyndication.com/pagead/show_ads.js"> 
</script></div><br>        <div align="center">        
            <a href="http://dragracecanada.com">
                <img src="http://www.dragracecanada.com/images/drc_wordpress_returnhome.gif" width="250" height="129" vspace="2" alt="DragRaceCanada.com" />
            </a>
        </div>


        <div class="clr"></div>
    </div>
    <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
</div>
</div>
<div class="clr"></div>




    <div id="dhtmlgoodies_slideshow">
	<div id="galleryContainer" align="center">
		<div id="arrow_left"><img src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/img/arrow_left.gif"></div>
		<div id="arrow_right"><img src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/img/arrow_right.gif"></div>
		<div id="theImages">
				<!-- Thumbnails -->
			<a href="http://www.mopar.com" target="_blank"><img src="http://www.dragracecanada.com/images/wordpress/mopar_chain.jpg"></a>
			<a href="http://www.lucasoil.ca" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2015/05/lucasoil_lg.gif"></a>
			<a href="http://www.vpracingfuels.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2014/05/vp_2014.gif"></a>
			<a href="http://www.castrolraceway.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2011/08/castrol_raceway.gif"></a>
			<a href="http://www.joestransmission.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/02/joestransmission.gif"></a>
			<a href="http://fasteddieracewear.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/fasteddie_logo_2016.gif"></a>
			<a href="http://www.charlesjones.ca/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/08/charles_jones_200x70.gif"></a>
			<a href="http://www.bigwestdodge.ca" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/03/bigwestdodge_th.jpg"></a>
			<a href="http://www.enationalperformance.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/NPW.png"></a>
			<a href="http://www.karbelt.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/Karbelt.png"></a>
			<a href="http://www.partspro.ca/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/01/PartsPro-CA.png"></a>
			<a href="http://www.acemfg.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/05/ace_mfg_152x70.gif"></a>
			<a href="http://www.boychuk.net/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2010/09/Boychuk182x70.gif"></a>
			<a href="http://www.artcal.com" target="_blank"><img src="http://www.dragracecanada.com/graphics/artcal.gif"></a>
			<a href="http://www.joestransmission.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2013/03/boniferro_185x70"></a>
			<a href="http://www.mellingselectperformance.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/mel.png"></a>
			<a href="http://www.arp-bolts.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/arp_190x70.gif"></a>
			<a href="https://www.flex-a-lite.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/flexalite_112x67.gif"></a>
			<a href="http://www.OconnorRV.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/04/oconner_142x70.gif"></a>
			<a href="http://www.energysuspension.com/" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/03/ene.png"></a>
			<a href="http://radtorque.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2017/07/RAD-200x70.gif"></a>			<!-- End thumbnails -->
				
				<div id="slideEnd"></div>
		</div>
	</div>
</div>
	<div id="bottompanel">
    <div class="roundcornrrbox">
        <div class="topleftcorner"><div class="toprightcorner"></div></div>
        <div class="roundcrrcnt">
        
        	
            <div class="col1">
                
					                    <h3>Recent Posts</h3>
                    <ul>
                                                    <li>
                                <a href="http://dragracecanada.com/the-more-muscle-the-better/">The More Muscle the Better </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/a-down-under-ultimatum/">A Down &#8220;Under Ultimatum&#8221; </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/season-three-finale/">Season Three Finale </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/heritage-points-pendulum-swings/">Heritage Points Pendulum Swings </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/canadian-photo-extra-bir-edition/">Canadian Photo Extra &#8211; BIR Edition </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/hot-cars-hot-topics-16/">Hot Cars &#8211; Hot Topics </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/2017-nhra-schedule/">2017 NHRA Schedule </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/lady-nitro-domination/">Lady Nitro Domination! </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/bene-motorsports-project-5-0/">Bene Motorsports &#8211; Project 5.0 </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/tribute-top-dragsters/">Tribute Top Dragsters </a>
                            </li>
                                                    <li>
                                <a href="http://dragracecanada.com/loudmusicloudcars-latest/">LoudMusicLoudCars &#8211; Latest! </a>
                            </li>
                        			
                    </ul>
                    

                            </div>
            
            <div class="col2">
                      
                    <h3>Archives</h3>
                    <ul>
                        	<li><a href='http://dragracecanada.com/2017/08/'>August 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/07/'>July 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/06/'>June 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/05/'>May 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/04/'>April 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/03/'>March 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/02/'>February 2017</a></li>
	<li><a href='http://dragracecanada.com/2017/01/'>January 2017</a></li>
	<li><a href='http://dragracecanada.com/2016/12/'>December 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/11/'>November 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/10/'>October 2016</a></li>
	<li><a href='http://dragracecanada.com/2016/09/'>September 2016</a></li>
                    </ul>

                            </div>
            
            <div class="clr"></div>
        

            <div class="clr"></div>
        </div>
        <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
    </div>
</div>
<!-- Bottom Panel ends -->


	
    <div class="copyr">Copyright &copy; 1996-2017 DragRaceCanada.com. All rights reserved.</div>    
    <div class="clr16"></div>
	</div>
    <div id="layoutbottom"></div>
</div>

<div id="credit" align="center">
	<abbr title="Jarrah/1.7">Jarrah</abbr> theme by <a href="http://www.templatesnext.org/">Templates Next</a> 
    | Powered by <a href="http://wordpress.org/">WordPress</a> 
</div>
	<div style="display:none">
	</div>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201735'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Augaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201735.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.0.3',blog:'26164618',post:'28451',tz:'-7',srv:'dragracecanada.com'} ]);
	_stq.push([ 'clickTrackerInit', '26164618', '28451' ]);
</script>

</body>
</html>