<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"  />
<title>More Norwalk Notoriety! &laquo;  DragRaceCanada.com</title>
<meta name="generator" content="WordPress 4.7.5" />
<meta name="robots" content="follow, all" />

<link rel="shortcut icon" href="http://dragracecanada.com/wp-content/themes/jarrah/favicon.ico" />
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="DragRaceCanada.com RSS Feed" href="http://dragracecanada.com/feed/" />
<link rel="pingback" href="http://dragracecanada.com/xmlrpc.php" />
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/css/menu.css" type="text/css" media="screen" />
<!--[if IE]><link rel="stylesheet" href="http://dragracecanada.com/wp-content/themes/jarrah/css/ie.css" type="text/css" media="screen" /><![endif]-->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/dragracecanada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='http://dragracecanada.com/wp-content/plugins/ditty-news-ticker/assets/fontastic/styles.css?ver=2.0.15' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='http://dragracecanada.com/wp-content/plugins/ditty-news-ticker/assets/css/style.css?ver=2.0.15' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='http://dragracecanada.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://dragracecanada.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.0.3' type='text/css' media='all' />
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/flash-album-gallery/admin/js/swfobject.js?ver=2.2'></script>
<script type='text/javascript' src='http://dragracecanada.com/wp-content/plugins/flash-album-gallery/admin/js/swfaddress.js?ver=2.4'></script>
<link rel='https://api.w.org/' href='http://dragracecanada.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://dragracecanada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://dragracecanada.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Retribution &#038; Reset Weekend!' href='http://dragracecanada.com/retrabution-reset-weekend/' />
<link rel='next' title='2017 NHRA Schedule' href='http://dragracecanada.com/2017-nhra-schedule/' />
<meta name="generator" content="WordPress 4.7.5" />
<link rel="canonical" href="http://dragracecanada.com/more-norwalk-notoriety/" />
<link rel='shortlink' href='http://wp.me/p1LMBY-7aG' />
<link rel="alternate" type="application/json+oembed" href="http://dragracecanada.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragracecanada.com%2Fmore-norwalk-notoriety%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://dragracecanada.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragracecanada.com%2Fmore-norwalk-notoriety%2F&#038;format=xml" />
<script type='text/javascript'>AC_FL_RunContent = 0;</script><script type='text/javascript' src="http://dragracecanada.com/wp-content/plugins/dynamic-headers/AC_RunActiveContent.js"></script><link rel="stylesheet" href="http://dragracecanada.com/wp-content/plugins/logo-slideshow/css/image-slideshow.css" type="text/css" media="screen" charset="utf-8"/>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/plugins/logo-slideshow/scripts/image-slideshow.js"></script>
	
<link rel="stylesheet" href="http://dragracecanada.com/wp-content/plugins/wp-photo-album/theme/wppa_style.css" type="text/css" media="screen" />
		
<!-- <meta name='Grand Flagallery' content='4.41' /> -->

<link rel='dns-prefetch' href='//v0.wordpress.com'>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="More Norwalk Notoriety!" />
<meta property="og:url" content="http://dragracecanada.com/more-norwalk-notoriety/" />
<meta property="og:description" content="Our report from NHRA’s “Grade A” annual touchdown event at fabulous Summit Racing Motorsports Park in Ohio…" />
<meta property="article:published_time" content="2017-06-27T13:49:01+00:00" />
<meta property="article:modified_time" content="2017-06-28T20:45:25+00:00" />
<meta property="og:site_name" content="DragRaceCanada.com" />
<meta property="og:image" content="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-400.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="250" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-400.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.pngFix.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.easing.min.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/jquery.lavalamp.min.js"></script>
<script type="text/javascript" src="http://dragracecanada.com/wp-content/themes/jarrah/js/my-menu.js"></script>

<!-- this product is released under General Public License. Please see the attached file for details. You can also find details about the license at http://www.opensource.org/licenses/gpl-license.php -->
<script type="text/javascript">
/* <![CDATA[ */

jQuery(document).ready(function(){ 
    jQuery(document).pngFix(); 
});

/* ]]> */ 
</script>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21904869-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<style type="text/css">

/* banner rotator styles */
div#banner_rotator  {
    width:960px; height:80px;
    padding:0px;
    background-color:#000;
}

div#banner_rotator span {
    display: block; text-align: center;
}

div#banner_rotator a:link,
div#banner_rotator a:visited, 
div#banner_rotator a:hover {
    color:#0F2F8D;
    text-decoration:none;
}

</style>

<script src="http://www.dragracecanada.com/js/dw_rotate_banner.js" type="text/javascript"></script>
<script type="text/javascript">

DYN_WEB.Event.domReady( function() {
    
    var banner = {
        id: 'banner_rotator', // id of element that displays rotating content
        speed: 6000, // default 4500
        bPause: false, // pause/resume onmouseover/out
        // banner content goes here
        // commas separate items, but no comma after last item
        content: ['<a href="http://www.mopar.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2016/12/high-performance-1.jpg" border="0"></span></a>',
            '<a href="http://www.lucasoil.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LucasOil-banner-2017.jpg" border="0"></span></a>',
	    '<a href="http://www.loudmusicloudcars.com/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LMLC-960X80-1.jpg" border="0"></span></a>'
        ]
    };
    
    new DYN_WEB.Banner_Rotator(banner);
    
});

</script>
</head>

<body>

<div id="wrapper" align="center">
	<div id="layouttop"></div>
    
    <!-- Header Starts -->
    <div id="header" align="center">
	<a href="http://www.dragracecanada.com/">
	    <img src="http://dragracecanada.com/wp-content/uploads/2014/12/DRC_Logo_trans.png" border="0">
	</a>
	<SPAN STYLE="font-family: Arial; font-size: 16px; font-decoration: bold; font-style: italic ; color: #FFFFFF"><br>proudly presented by:&nbsp;&nbsp;</SPAN>
	<br>
	<br>
	<div id="banner_rotator"><a href="http://www.lucasoil.ca/" target="_blank"><span><img src="http://dragracecanada.com/wp-content/uploads/2017/02/LucasOil-banner-2017.jpg" border="0"></span></a></div>
    	<!-- 				<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="990" height="150" id="mediaHeader" align="middle">
				<param name="allowScriptAccess" value="sameDomain" />
				<param name="allowFullScreen" value="false" />
				<param name="wmode" value="transparent" />
				<param name="movie" value="http://dragracecanada.com/wp-content/header-images/DRC2013.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" />	
				<embed src="http://dragracecanada.com/wp-content/header-images/DRC2013.swf" wmode="transparent" quality="high" bgcolor="#ffffff" width="990" height="150" name="mediaHeader" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
				</object>
		 -->        
    </div>
    <!-- Header Ends -->

    <div id="innerwrapper">

    	
        <!-- Main nav Starts here -->
<!--
        <div id="navouter">
            <div id="nav">

<ul class="lavalamp" id="menu1">  
<li class="page_item "><a href="http://dragracecanada.com">Home</a></li> 
		<li class="cat-item cat-item-10"><a href="http://dragracecanada.com/category/performance-pipeline/" >BWD Performance Pipeline</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://dragracecanada.com/category/editors-extra/" >Editor&#039;s Extra</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://dragracecanada.com/category/hoctcars-hottopics/" >Hot Cars Hot Topics</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://dragracecanada.com/category/international-dateline/" >International Dateline</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://dragracecanada.com/category/hotzone/" >Lucas Oil Hotzone</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://dragracecanada.com/category/national-news/" >Mopar Canada &#8211; National News</a>
</li>
	<li class="cat-item cat-item-9"><a href="http://dragracecanada.com/category/northern-exposure/" >Northern Exposure</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://dragracecanada.com/category/team-blogs/" title="Team Blogs">Paton Racing Blog</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://dragracecanada.com/category/photo-gallery/" >Photo Gallery</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://dragracecanada.com/category/unassigned/" >Unassigned</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://dragracecanada.com/category/the-pro-mod-portal/" >VP Racing Pro Mod Portal</a>
</li>
		 	
</ul> 
          
            </div>
        </div>
 //-->
        <!-- Main nav Ends -->
<div id="maincol">

<br><div align="center"><a href="http://www.mopar.ca" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2016/12/570-high-performance-1.jpg" border="0" width="570" height="70" alt="Mopar"></a></div><br>
		
        <div class="postwrap">
          	<h2 class="posttitle"><a href="http://dragracecanada.com/more-norwalk-notoriety/">More Norwalk Notoriety!</a></h2>
          	<div class="postmeta">by <a href="http://dragracecanada.com/author/editor/" title="Posts by editor" rel="author">editor</a> on Jun.27, 2017, under <a href="http://dragracecanada.com/category/national-news/" rel="category tag">Mopar Canada - National News</a></div>
            <div class="clr16"></div>
          	<div class="postcontent"><p><em>Our report from NHRA’s “Grade A” annual touchdown event at fabulous Summit Racing Motorsports Park in Ohio…</em><span id="more-27570"></span><a href="http://dragracecanada.com/norwalk-sign/"><img class="aligncenter size-full wp-image-27567" src="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-sign.jpg" alt="" width="500" height="432" srcset="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-sign.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-sign-300x259.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-sign-318x275.jpg 318w" sizes="(max-width: 500px) 100vw, 500px" /></a><br />
Steve Torrence powered his Top Fuel dragster to victory during the 11th annual Summit Racing Equipment NHRA Nationals as did Jack Beckman (Top Fuel), Bo Butner (Pro Stock) and LE Tonglet (Pro Stock Motorcycle). The marquee race marked the half-way point (12th of 24 events) for the 2017 NHRA Mello Yello Drag Racing Series schedule.</p>
<p>Torrence secured his career-best fourth victory of the season with a 3.743-second pass at 331.45 mph in his Capco Contractors dragster to defeat Doug Kalitta on a holeshot after he ran a 3.736 at 331.36 in his Mac Tools dragster. Torrence emerged victorious for the first time since Englishtown, and has now reached six final rounds on the season, with all six coming over the past eight events.</p>
<div id="attachment_27569" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/norwalk-torrence/"><img class="size-full wp-image-27569" src="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Torrence.jpg" alt="" width="500" height="324" srcset="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Torrence.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Torrence-300x194.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Torrence-400x259.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Texan Steve Torrence maintained his NHRA Top Fuel points lead with his 4th win of the 2017 campaign.</p></div>
<p>“I knew I left good on the tree but I could tell it would just be a coin toss who got it and fortunately I was able to come out ahead,” Torrence said. “It’s been a great season so far and we are hoping to keep this momentum going. We just need to keep our head down and work hard so that we can reach our goals as a team.”</p>
<p>Torrence qualified third and defeated Troy Coughlin Jr., Clay Millican and Brittany Force on the way to victory. Kalitta knocked off Troy Buff, Tony Schumacher and Leah Pritchett before reaching his second final round appearance of the season.</p>
<p>Torrence remained atop the points standings with the victory and Leah Pritchett is second in the standings after a semifinal appearance.</p>
<p>Beckman earned his 26th career victory and second of the season with a 4.073 pass at 311.85 in his Infinite Hero Foundation Dodge Charger R/T during the final round to defeat Robert Hight who ran a 6.673 at 98.53 in his Auto Club of Southern California Chevrolet Camaro SS. This was Beckman’s first win since Englishtown, and his third consecutive final round appearance this season.</p>
<div id="attachment_27559" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/norwalk-jackb-2/"><img class="size-full wp-image-27559" src="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-JackB.jpg" alt="" width="500" height="319" srcset="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-JackB.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-JackB-300x191.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-JackB-400x255.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Jack Beckman continued the amazing DSR dominance in NHRA fuel FC racing this year &#8212; when he notched his 26th career victory.</p></div>
<p>“We were consistently a bit off this weekend, but we are definitely happy to earn the victory this weekend,” Beckman said. “Now that we are getting down the track consistently, it keeps our opponents honest and that is definitely a formula we will continue to use for the rest of the season.”</p>
<p>Beckman qualified ninth and defeated Cruz Pedregon, Matt Hagan and Tommy Johnson Jr. before reaching his third final round of the season. Hight reached his second final round of the season after defeating Jim Campbell, Alexis DeJoria and Bob Tasca III.</p>
<p>Beckman remains in third place in the points standings behind teammatesRon Capps and Matt Hagan, who both fell in the quarterfinals.</p>
<p>Points leader Butner secured the victory in Pro Stock after driving to a 6.601 at 210.50 in his Jim Butner’s Auto Chevy Camaro to knock off Greg Anderson on a holeshot after running a 6.581 at 210.87 in his Summit Racing Equipment Chevrolet Camaro. Butner now has three victories on the year as he notched his first win since Atlanta.</p>
<div id="attachment_27558" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/norwalk-butner2/"><img class="size-full wp-image-27558" src="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Butner2.jpg" alt="" width="500" height="296" srcset="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Butner2.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Butner2-300x178.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Butner2-400x237.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Bo Butner has moved to the top in NHRA&#8217;s Pro Stock class standings by winning at Norwalk</p></div>
<p>“Today was a great day, we made four pretty consistent runs and my car was good when it needed to be,” Butner said. “It’s one thing to have a good car, but we also had a lot of things go our way to get those win lights today.”</p>
<p>Butner had the second-best qualifying time and defeated Val Smeland, Vincent Nobile and John Gaydosh en route to his fifth final round of 2017. Anderson earned his sixth final round appearance of the season by defeating Mark Hogan, Allen Johnson and Jason Line.</p>
<p>Butner added to his lead in the points standings, becoming the first three race winner in the Pro Stock category this season. Anderson remains in second place with his fourth runner-up appearance of the year.</p>
<p>In Pro Stock Motorcycle, Tonglet emerged victorious with a 6.824 at 195.76 in his Nitro Fish Racing Suzuki to defeat Matt Smith’s pass of 6.882 at 195.31 in his Victory Polaris Magnum. Tonglet notched his 13th career victory and third of the season.</p>
<p>“I didn’t see any win lights throughout qualifying, but seeing them on Sunday is what matters and we are happy with the results,” Tonglet said. “This is huge for us and our position in the points standings, so getting as many wins as possible is definitely our goal.”</p>
<p>Tonglet has now reached three final rounds in five events this season, winning all three of those appearances. He defeated Melissa Surber, Steve Johnson and Hector Arana Jr. before the final round. Smith took on Joe DeSantis, Mike Berry and Scott Pollacheck before reaching his first final round of the season.</p>
<div id="attachment_27565" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/norwalk-psb/"><img class="size-full wp-image-27565" src="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-PSB.jpg" alt="" width="500" height="289" srcset="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-PSB.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-PSB-300x173.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-PSB-400x231.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">With his victory &#8211; LE Tonglet now sits at the top in NHRA season Pro Stock Motorcycle points</p></div>
<p>Tonglet jumped to first in the Pro Stock Motorcycle points standings and Eddie Krawiec fell to second after falling in the first round.</p>
<p style="text-align: center;"><strong>First Win for Fast Car!</strong></p>
<p>Pacific Northwest based racer Shane Molinari, who had set top speed of the meet in NHRA Pro Mod class racing 5X this season — has finally turned that wickedly fast pace into victory.</p>
<p>Molinari raced to his first career NHRA J&amp;A Service Pro Mod Drag Racing Series victory during the Summit Racing Equipment NHRA Nationals at Summit Racing Equipment Motorsports Park &#8211; a victory which is seen my many as much overdue.</p>
<div id="attachment_27562" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/norwalk-pmp-shane/"><img class="size-full wp-image-27562" src="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-PMP-Shane.jpg" alt="" width="500" height="343" srcset="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-PMP-Shane.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-PMP-Shane-300x206.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-PMP-Shane-400x275.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Shane Molinari sped to a convincing first victory in J&amp;A Services Pro Mod class racing.</p></div>
<p>The weekend’s Pro Mod racing, presented by the Real Pro Mod Association, was the eighth of 12 events on the 2017 schedule.</p>
<p>The finals were a re-match from the race in Bristol where Molinari (from Washington state) faced off against Ohio&#8217;s Troy Coughlin who took that event win. In Norwalk, Molinari was able to reverse the outcome for the victory.</p>
<p>Coughlin had an early advantage off the line but lost traction past the 330 foot mark and Molinari posted a winning run of 5.779-seconds at 257.09 mph in his S&amp;T Truck Repair Inc/RAD turbocharged &#8217;68 Firebird to the trailing run of 11.743 at 69.91.</p>
<p>“It’s unbelievable, it’s way cool,” said Molinari. “I mean, all my guys worked super hard and it’s just an awesome feeling.&#8221;</p>
<p>Racing his turbocharged machine which is tuned by industry expert Brad Personett, Molinari, after qualifying 3rd for the very swift field (5.906 secs bump) had beaten Canadian Eric Latino, Steve “Fast” Jackson and Rickie Smith in earlier rounds of competition.</p>
<p style="text-align: center;"><em><strong>The Lucas Oil Lowdown</strong></em></p>
<p><a href="http://dragracecanada.com/four-wide-fortunes/lucas-oil-drs1-e1452447248849-2/" rel="attachment wp-att-26991"><img class="aligncenter size-full wp-image-26991" src="http://dragracecanada.com/wp-content/uploads/2017/05/Lucas-Oil-DRS1-e1452447248849-2.jpg" alt="" width="500" height="233" srcset="http://dragracecanada.com/wp-content/uploads/2017/05/Lucas-Oil-DRS1-e1452447248849-2.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/05/Lucas-Oil-DRS1-e1452447248849-2-300x140.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/05/Lucas-Oil-DRS1-e1452447248849-2-400x186.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><br />
Jeff Strickland and Nick Folk both doubled up, winning in two different classes, and Jackie Fricke and Andy Bohl won in Top Alcohol Dragster and Funny Car respectively at the Summit Racing Equipment NHRA Nationals at Summit Motorsports Park in Norwalk, Ohio</p>
<p>Strickland raced to the second double up in his career winning in both Top Dragster presented by Racing RV’s and Stock Eliminator while Folk became the 23rd racer to double in NHRA history and just the fifth driver in history to notch national event wins in six different classes.</p>
<div id="attachment_27560" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/norwalk-jeffs/"><img class="wp-image-27560 size-full" src="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-JeffS-e1498571124979.jpg" alt="" width="500" height="357" /></a><p class="wp-caption-text">Defending World Champion Jeff Strickland won in both Stock eliminator and also in Top Dragster</p></div>
<p>Strickland, Rad Bay, Ala., raced to a 6.338 second, 209.17 mph lap on his 6.33 dial to defeat Kathy Fisher in Top Dragster as Fisher ran too quick and broke out. In the Stock final round, Strickland drove his ’17 Camaro to the win over Jim Boburka for his 16th overall NHRA national event trophy.</p>
<p>Folk, Durand, Ill., first meet up with Tony Helms in Super Comp. Helms had the early lead but broke out and Folk clocked in at 8.925, 165.46. Folk then lined up against Zack Running in Super Stock and secured his double when Running left early with a red light. The win in Super Stock marked the sixth different class that Folk has won an NHRA national event in.</p>
<p>Fricke, Flemington, N.J., ran 5.20’s and 5.30’s throughout eliminations to advance to the final in Top Alcohol Dragster against former Lucas Oil world champion Chris Demke who broke on his burn out. Fricke, who qualified No. 6, took the easy win, her second of her career.</p>
<div id="attachment_27568" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/norwalk-tad/"><img class="size-full wp-image-27568" src="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-TAD.jpg" alt="" width="500" height="337" srcset="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-TAD.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-TAD-300x202.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-TAD-400x270.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">For the second time in her career &#8211; Jackie Fricke won in TAD class racing</p></div>
<p>Bohl, Racine, Wis., took the early lead on Chris Foster, Davenport, Iowa, in Top Alcohol Funny Car and powered to his forth national event win as Foster spun the tires at the hit of the throttle. Bohl crossed the finish line in 5.631 seconds at 248.93 mph.</p>
<p>In the SAM Factory Stock Showdown it was a pair of Mustangs going to battle as Charles Watson bagged his first Factory Stock win with a run of 8.190 seconds at 165.25 mph in defeating Kevin Skinner who spun the tires and slowed to a 10.539, 112.02.</p>
<div id="attachment_27555" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/norwalk-bohl/"><img class="size-full wp-image-27555" src="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Bohl.jpg" alt="" width="500" height="358" srcset="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Bohl.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Bohl-300x215.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Bohl-384x275.jpg 384w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Andy Bohl was the winner in Lucas Oil TAFC class car competition.</p></div>
<p>&nbsp;</p>
<p>Other racers visiting the winner’s circle were Jeffrey Barker who grabbed his sixth win on the national circuit in beating Ricky Adkins in Top Sportsman presented by Racing RVs; Rob Kropfeld scored in Super Gas over Trevor Larson for his second; and Brian Spotts drove his Anglia to the AA Gas win against Alan Borowski.</p>
<div id="attachment_27566" style="width: 509px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/norwalk-sg-2/"><img class="size-full wp-image-27566" src="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-SG.jpg" alt="" width="499" height="367" srcset="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-SG.jpg 499w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-SG-300x221.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-SG-374x275.jpg 374w" sizes="(max-width: 499px) 100vw, 499px" /></a><p class="wp-caption-text">Rick Kropfield raced his slick little Chevy Vega Wagon to the event&#8217;s 9.90 Super Gas title</p></div>
<p style="text-align: center;"><strong>COMP Eliminator Roundup!</strong></p>
<p>For the sixth time this season, the top players in Competition Eliminator competed at the 11th annual Summit Racing Equipment NHRA Nationals at Summit Motorsports Park.</p>
<p>The Competition Eliminator class experienced rare abbreviated qualifying before raceday due to Mother Nature sticking around for the majority of Friday’s competition. After the two rounds of qualifying, Chuck Haubiel was the No. 1 qualifier in his 2010 Chevrolet Cobalt after going .753-seconds under his C/SM index.</p>
<div id="attachment_27556" style="width: 510px" class="wp-caption aligncenter"><a href="http://dragracecanada.com/more-norwalk-notoriety/norwalk-bruno/" rel="attachment wp-att-27556"><img class="size-full wp-image-27556" src="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Bruno.jpg" alt="" width="500" height="340" srcset="http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Bruno.jpg 500w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Bruno-300x204.jpg 300w, http://dragracecanada.com/wp-content/uploads/2017/06/Norwalk-Bruno-400x272.jpg 400w" sizes="(max-width: 500px) 100vw, 500px" /></a><p class="wp-caption-text">Bruno Massel scored in Comp with his super quick turbocharged Chevy Cobalt</p></div>
<p>In the first round of competition, James Primozic Jr. took out his father Jim Primozic in the first after his father was a no show to the matchup. Ray Skillman took out Greg Kamplain when Kamplain went -.012-seconds red at the hit. Other winners in the first round were Lee Zane, Doug Doll Jr., Patrick Ross, Larry Morgan, Frank Aragona, David Rampy, Brian Savani, Jim Greenheck, Troy Galbraith, Bruno Massel, and Robert Bailey.</p>
<p>Second round, Bruno Massel’s .026-second reaction time was the best of the round and it also assisted him in defeating Robert Bailey in that round. Former Pro Stock racer Larry Morgan advanced to the third round after taking the green light on his bye run. Other winners in the second round include David Rampy, James Primozic Jr., Lee Zane, Patrick Ross, and Troy Galbraith.</p>
<p>In the third round, Troy Galbraith took out Lee Zane after Zane reacted too early by .003-seconds and turned on the red light. Notably, Larry Morgan showed his strength as a driver when he had a .002-second reaction time – the best reaction time of the round. Other winners in the third round were Bruno Massel and Patrick Ross.</p>
<p>In the semifinal round, Bruno Massel defeated Patrick Ross when he had over two tenths starting line advantage over Ross and drove it to the finish line victory. Larry Morgan took out Troy Galbraith when he clocked in with a 7.083 on his 7.52 B/A index.</p>
<p>The final round was a matchup of the former Pro Stock racers of Larry Morgan and Bruno Massel. Morgan launched too quickly with a -.056-second red light and coasted to the finish line with a 7.609. Massel was able to see the win light turn on his lane and let off before the finish line in order to not hurt his index. He clocked in with a 7.472.</p>
<p>This win is Massel’s second of the season and his 12th of his career. Eleven of his wins have been in Competition Eliminator.</p>
<p style="text-align: center;"><em>Posted with files by NHRA Communications, Bruce Biegler, Eric Lotz &amp; Sadie Floyd</em><br />
<em>Photos by Dave DeAngelis and Brennan Shortall</em></p>
<p style="text-align: center;">To view addition images from NHRA Norwalk &#8211; link to our event photo gallery: <a href="http://loudmusicloudcars.com/2017/06/nhra-norwalk-2017/"><strong>HERE</strong> </a></p>
</div>
          	<div class="clr"></div>
          	<span class="linkpages"></span><div class="cleared"></div>
          	
			            
				<div class="roundcornrrbox">
                   	<div class="topleftcorner"><div class="toprightcorner"></div></div>
                    <div class="roubcornrcontent">
            			<span class="posttags-single"><a href="http://dragracecanada.com/tag/bo-butner/" rel="tag">Bo Butner</a>, <a href="http://dragracecanada.com/tag/jack-beckman/" rel="tag">Jack Beckman</a>, <a href="http://dragracecanada.com/tag/shane-molinari/" rel="tag">Shane Molinari</a>, <a href="http://dragracecanada.com/tag/steve-torrence/" rel="tag">Steve Torrence</a></span>
                    	<div class="clr"></div>
                    </div>
                    <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
                </div>                        
                        
			
			        	
            <div class="clr"></div>
        </div> <!-- Closes topPost -->
		<small></small>

		<div id="comments">
			            <!-- WP 2.7 and above -->
                        
                    </div> <!-- Closes Comment -->

<div id="extrastuff">
<span id="rssleft"><a href="http://dragracecanada.com/more-norwalk-notoriety/feed/"><abbr title="Really Simple Syndication">RSS</abbr> feed for this post (comments)</a></span>

<span id="trackright"></span>
<div class="cleared"></div>
</div>


<br><div align="center"><a href="http://www.nitrofccanada.com" target="_blank"><img src="http://dragracecanada.com/wp-content/uploads/2012/07/nitrofccanada_com_chrome_570x109.jpg" width="570" height="109" border="0"></a></div><br>
</div><!-- Closes Main -->


<div id="rightcol">
	<div class="roundcornrrbox">
    <div class="topleftcorner"><div class="toprightcorner"></div></div>
    <div class="roundcrrcnt">
    

        	<div id="searchboxo">
        		<form method="get" id="searchform" action="http://dragracecanada.com/">
    <input type="text" value="Search DragRaceCanada" name="s" id="searchbox" onfocus="this.value=''" class="searchinput"/>
    <input type="submit" class="submitbutton" value="Search" />
</form> 
        </div>

        <!-- widget -->
                    <div class="widget-cat">
                <h4>Categories</h4>
                <ul>
                    	<li class="cat-item cat-item-10"><a href="http://dragracecanada.com/category/performance-pipeline/" >BWD Performance Pipeline</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://dragracecanada.com/category/editors-extra/" >Editor&#039;s Extra</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://dragracecanada.com/category/hoctcars-hottopics/" >Hot Cars Hot Topics</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://dragracecanada.com/category/international-dateline/" >International Dateline</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://dragracecanada.com/category/hotzone/" >Lucas Oil Hotzone</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://dragracecanada.com/category/national-news/" >Mopar Canada &#8211; National News</a>
</li>
	<li class="cat-item cat-item-9"><a href="http://dragracecanada.com/category/northern-exposure/" >Northern Exposure</a>
</li>
	<li class="cat-item cat-item-15"><a href="http://dragracecanada.com/category/team-blogs/" title="Team Blogs">Paton Racing Blog</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://dragracecanada.com/category/photo-gallery/" >Photo Gallery</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://dragracecanada.com/category/unassigned/" >Unassigned</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://dragracecanada.com/category/the-pro-mod-portal/" >VP Racing Pro Mod Portal</a>
</li>
                </ul>
            </div>

<div align="center"><img src="http://dragracecanada.com/wp-content/uploads/2013/04/mopar_national_news.gif" border="0" vspace="4"><br><br></div>

         

        <br><div align="center"><script type="text/javascript"><!--
google_ad_client = "pub-9456405457314885";
google_ad_width = 120;
google_ad_height = 600;
google_ad_format = "120x600_as";
google_ad_channel ="";
google_color_border = "666666";
google_color_bg = "000000";
google_color_link = "FFFFFF";
google_color_url = "FF0000";
google_color_text = "FF0000";
//--></script>
<script type="text/javascript"
  src="http://pagead2.googlesyndication.com/pagead/show_ads.js"> 
</script></div><br>        <div align="center">        
            <a href="http://dragracecanada.com">
                <img src="http://www.dragracecanada.com/images/drc_wordpress_returnhome.gif" width="250" height="129" vspace="2" alt="DragRaceCanada.com" />
            </a>
        </div>


        <div class="clr"></div>
    </div>
    <div class="bottomleftcorner"><div class="bottomrightcorner"></div></div>
</div>
</div>
<div class="clr"></div>




<br />
<b>Parse error</b>:  syntax error, unexpected $end in <b>/home/content/d/r/c/drcanada/html/wp-content/themes/jarrah/footer.php</b> on line <b>27</b><br />
<script type='text/javascript' src='http://stats.wp.com/e-201726.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.0.3',blog:'26164618',post:'27570',tz:'-7',srv:'dragracecanada.com'} ]);
	_stq.push([ 'clickTrackerInit', '26164618', '27570' ]);
</script>
